Closed Bug 534431 Opened 10 years ago Closed 10 years ago

Error in Identifying the 'To' name in Message Window

Categories

(Thunderbird :: Message Reader UI, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 478466

People

(Reporter: kurt, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091211 Shredder/3.0.1pre

The message bar has the 'to' identified as 'you' in (some cases).
Clicking on the * next to you, brings up a persons name but that person is not the correct one for the email address to which the email was sent!

Reproducible: Always

Steps to Reproduce:
1.In the AB enter the same email xx  in a number of contact cards in different AB's
2.Download messages addressed to the xx email
3.Open the email and check the name for 'to'.
4. Note that this is arbitrary and strange as a name is just picked out by lottery and will be wrong in any event.
Actual Results:  
Strange, inexplicably behavior.

Expected Results:  
The 'to' should never state 'you'; as this is impossible unless you have put your own name and details into the address book.
It should always display the email address to which the message was sent

Wasting programming time and effort on trying to second guess the name from lists in one or the other address books is  a complete waste of effort
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: me-header
You need to log in before you can comment on or make changes to this bug.