Spell Checker Does Not Load Dictionary Contents

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Daniel Bruce Lynes, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

It seems that the spell checker in Thunderbird 3 on the Windows platform, specifically on Windows XP Home Edition (not sure if it happens on other Windows versions or not) does not appear to load the dictionaries.  It allows you to switch between the dictionaries, but does not appear to load the data, and so every word is highlighted as a spelling error.
This problem definitely does not happen in Linux on Thunderbird 3, or on Windows in Thunderbird 2.0.0.xx.

Reproducible: Always

Steps to Reproduce:
1. Click Compose
or
2. Click Reply on an existing message
or
3. Click Reply All on an existing message
Actual Results:  
Spelling dictionary does not seem to be loaded; tried installing another dictionary, and it's still the same results.

Expected Results:  
Expected it to load the spelling dictionary so that only misspelled words are highlighted, not all words.
(Reporter)

Comment 1

8 years ago
If you need me to do anything technical, please feel free to ask me, as long as it doesn't require me to pull up a development environment on Windows.
Version: unspecified → 3.0
Can you try disabling all add-ons and extensions and see if it works better ?

Anything in Tools -> Error console ?
(Reporter)

Comment 3

8 years ago
All add-ons were already disabled except for the Canadian English dictionary.

I tried composing email and replying to email first thing this morning before my wife got on her machine, and the spell checker's working just fine.

I suspect there's some intermediate steps she's doing to get to that point that she either doesn't remember doing, or could care less about, that she's not telling me about.  I don't think I'm going to get much cooperation either...she hates the new version, because the interface is different from the old version.

When it happens again though, I should be able to get the error console for you.  That being said, even when it is working, there's still plenty of errors and warnings in the error console, but the spell checker seems to be working.
(In reply to comment #3)
 
> I tried composing email and replying to email first thing this morning before
> my wife got on her machine, and the spell checker's working just fine.

Thanks - I'll set a marker and we'll close the bug in month if we don't hear from you.

> hates the new version, because the interface is different from the old version.

Feedback is welcome - even negative , at http://www.getsatisfaction.com/mozilla_messaging.
Whiteboard: closeme 2010-01-28
(Reporter)

Comment 5

8 years ago
The email spellchecker issue seems to rear its ugly head after Thunderbird's been sitting idle for a while (about 15 minutes to 1/2 hour).  As an additional note, there was an error that popped up when I tried to open a specific imap folder's inbox, after the spelling engine started having its issue.  I had to leave in a rush however, and so never got a chance to write the error down, or do a screen capture.  When I get a chance to catch it again, I will.  As a side note, I had gotten that error on Linux as well (but on a Gmail imap account), removed the account, and recreated it again, and no more problems on the Linux machine.

I get this in the Error Console:

Error: [Exception... "'JavaScript component does not have a method named: "handleEvent"' when calling method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "<unknown>"  data: no]
uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.msgDatabase]" nsResult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/mailWidgets.xml :: parseFolder :: line 2076" data: no]
uncaught exception: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIMsgFolder.msgDatabase]" nsResult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)" location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird/modules/dbViewWrapper.js :: folderNotificationHelper_notifyOnLoad :: line 131" data: no]
uncaught exception: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIMsgFolder.msgDatabase]" nsResult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)" location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird/modules/dbViewWrapper.js :: folderNotificationHelper_notifyOnLoad :: line 131" data: no]
uncaught exception: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIMsgFolder.msgDatabase]" nsResult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)" location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Thunderbird/modules/dbViewWrapper.js :: folderNotificationHelper_notifyOnLoad :: line 131" data: no]
uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.msgDatabase]" nsResult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/mailWidgets.xml :: parseFolder :: line 2076" data: no]
(Reporter)

Comment 6

8 years ago
As a side note, is there any way to copy the entire contents of the error log, or select which entries you want to copy, save for a screen capture?  It only seems to allow me to do single entry copies.

Thanks.
(In reply to comment #6)
> As a side note, is there any way to copy the entire contents of the error log,
> or select which entries you want to copy, save for a screen capture?  It only
> seems to allow me to do single entry copies.

Not yet :-(
Whiteboard: closeme 2010-01-28
(Reporter)

Comment 8

8 years ago
Fwiw, the spell checker issue seems to have resolved itself somehow.
WFM per comment 8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.