Starting Firefox in full-screen causes strange behavior

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Matthew Turnbull [Bluefang], Unassigned)

Tracking

({regression})

3.6 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20091212 Minefield/3.7a1pre Firefox/3.7
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20091212 Minefield/3.7a1pre Firefox/3.7

When Firefox is started in full-screen mode, I notice the following behavior:

- The window is full-screen, however the toolbars appear as if not in full-screen mode

- exiting then re-entering full-screen mode will display the toolbars as expected

- after exiting full-screen mode, closing any dialog (preference, check for updates, javascript alert) will cause Firefox to go back into the pseudo full-screen mode


Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Enter full-screen mode
3. Restart Firefox
4. Exit full-screen mode
5. Open then close a dialog
Actual Results:  
After #3, the window should be in pseudo full-screen mode
After #5, it should be back in pseudo full-screen mode

Expected Results:  
After #3, the window should be in full-screen mode
After #5, nothing should happen
(Reporter)

Comment 1

8 years ago
I should also mention that this happens in both Firefox 3.6 and Trunk.

This doesn't happen in Firefox 3.5, which doesn't appear to have the ability of starting in full-screen mode.
Hardware: x86 → x86_64
Version: unspecified → Trunk

Updated

8 years ago
Keywords: regression, regressionwindow-wanted
Version: Trunk → 3.6 Branch
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
(Reporter)

Comment 3

7 years ago
Yes, I still see the problem in the latest 3.6 nightly.

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.15pre) Gecko/20110203 Namoroka/3.6.15pre

If you quit Firefox 3.6 while in full-screen mode, the next time Firefox is opened it will start in full-screen mode, but with no window controls and all of the toolbars visible.

However, I no longer see the issue with dialogs re-triggering the pseudo full-screen mode.

This problem is not in Firefox 4.
We'll close as WFM since this is FIXED in firefox 4 but we don't know what exactly did it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.