Horizontal scroll in search results

VERIFIED INVALID

Status

()

Bugzilla
Query/Bug List
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: KitchM, Unassigned)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091106 Shiretoko/3.5.5
Build Identifier: 

There is a problem with the search results box at the top of the bug creation page.  Sometimes it has a horizontal scroll bar and sometimes it doesn't.  This is odd when the format of the results is the same.

Reproducible: Always

Steps to Reproduce:
1.Type in a search word or phrase and press Search.
2.See results.
3.Repeat and compare results displays.
Actual Results:  
Sometimes there is a scroll bar and sometimes there isn't.

Expected Results:  
There should never be a horizontal scroll bar.

Comment 1

9 years ago
No idea which search results box you are talking about, especially in the bug creation page. Please attach a screenshot. Marking as INVALID for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Please note the attachments.  Each search results box appears to have a different format.
(Reporter)

Comment 3

9 years ago
Created attachment 417427 [details]
First screen
(Reporter)

Comment 4

9 years ago
Created attachment 417429 [details]
Second screen
(Reporter)

Comment 5

9 years ago
Created attachment 417430 [details]
Third screen

Comment 6

9 years ago
ok, that's because bug 516047, which appears in your 2nd screen, has a very long word in its summary: nsXULTreeGridCellAccessible::GetAttributesInternal(nsIPersistentProperties*)] and so Firefox cannot break this word to make the summary small enough to fit within your window. That's why you see the horizontal scrollbar. So that's not a bug. :)
(Reporter)

Comment 7

9 years ago
Wow! Its not a bug, but it is because of a bug?  Really?

The sad fact of the matter is that the coding has not been designed properly to break these long strings and phrases as convenient places with a standard notation.  One might even go farther and question why the string is there in the first place.

The other fact remains: no web page or form anywhere should have a horizontal scrollbar.  Period.  Nothing is so important as to override ease of use.  That would be simply sloppy design.  It needs to be fixed right away.
Status: RESOLVED → VERIFIED

Comment 8

9 years ago
(In reply to comment #7)
> Wow! Its not a bug, but it is because of a bug?  Really?

I never said it's because of a bug. Not splitting long words is not a bug.


> The sad fact of the matter is that the coding has not been designed properly to
> break these long strings and phrases as convenient places with a standard
> notation.  One might even go farther and question why the string is there in
> the first place.

Totally irrelevant.


> The other fact remains: no web page or form anywhere should have a horizontal
> scrollbar.  Period.

Based on what? If you don't like the way Firefox behaves, either fix this problem yourself by offering a patch to the Firefox team, or use another "much better and doing the right thing" browser.
(Reporter)

Comment 9

9 years ago
Oh, you meant the bug as an example of a long word.  I miss-read it.  Sorry.

Okay, so the issue that a long word cannot be split is not a bug.  Well, we can still call it an annoyance, since it could be split if the form designer had specified a breakpoint for such "words".  And that is relevant since such would be the logical outcome as a solution to my issue.

I don't see any reason for a change to Firefox.  Rather, this problem is always about the design of web pages, which Firefox just displays as designed.  Hence the reason for reporting under Bugzilla itself.

I would like the web-site form designer to find a way, if possible, to constrain the width to a percentage of the whole, and to force all text to hyphenate and wrap as needed.  If readers become confused, long "words" could be highlighted in some manner to note that the parts all go together.  Perhaps it is just a matter of employing proper hyphenation, as is done in normal text situations.
You need to log in before you can comment on or make changes to this bug.