Cannot type {}[]<> on some keyboards

RESOLVED DUPLICATE of bug 478389

Status

RESOLVED DUPLICATE of bug 478389
9 years ago
9 years ago

People

(Reporter: julian.viereck, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; de-de) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: tip

On non US keyboards you need to hold down CTRL, or ALT, or CMD, or ALTGR + another key to insert characters like {}[]<>. Bespin sometimes stops these key combinations and as this it's not possible to get a certain character be added in the bespin editor.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
For german keyboards on mac I could fix things a little bit bz removing some lines in getPrintableChar(). I have no idea why I added them.

See the patch here: http://bitbucket.org/j4c/bespinclient/changeset/c3c2013971b5/

When I tested things on a Windows machine with Switzerland keyboard, it turned out that the []{} characters don't work on chrome. Things can't be fixed here, because the information provided within the onkeydown event are not enough to figure out if this event should be stopped or not. At the moment the onkeypress event is suppressed and the mentioned chars don't show up in chrome.

In general, this bug is terrible to be fixed, as to make sure it works for all OS + keyboard combinations you have to test it on every OS + keyboard configuration. The combinations to access certain characters like [] are always a little bit different and as well the keycodes within the events differ a little bit.
(Reporter)

Comment 2

9 years ago
Okay, I know now why I added these lines in getPrintableChar(). Without them, the CMD + T etc. combos don't get through to the browser. I have backed out that change from my repo again.

This bug is still up to get fixed.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 478389
You need to log in before you can comment on or make changes to this bug.