Web content not displaying in HP Printing dialog and you get crash when printing

VERIFIED DUPLICATE of bug 54004

Status

()

Core
HTML: Form Submission
P1
normal
VERIFIED DUPLICATE of bug 54004
18 years ago
17 years ago

People

(Reporter: bijals (gone), Assigned: waqar)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm need info])

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Steps:
1) Open Navigator
2) Copy and paste following URL and hit return
http://hpprintit.com/jsp/option1/test.html

3) Click on the 2nd or 3rd Print buttons
4) Click print to start printing

Actual Results: HP branded Print dialog comes does not include Web page to be 
printed.  Please look at screen shots to compare with same dialog in 
Communicator.  Clicking print on final dialog crashes Seamonkey.

Expected Results: HP branded Print dialog appears the same as image of 
Communicator experience.  Clicking print does not crash Seamonkey.

Build Date/Platform: 2000092005 using NT
(Logging bug for HP folks)
(Reporter)

Comment 1

18 years ago
Created attachment 15161 [details]
HP branded Print Dialog as expected in Communicator 4.74
(Reporter)

Comment 2

18 years ago
Created attachment 15163 [details]
HP branding Print dialog that is broken in N6

Comment 3

18 years ago
I think I have distinlled this down correctly, if not, well I have found yet a 
different bug. This example requires 4 file which I will include as a zip file 
attachment. Basically, it is a frameset where an onload handle in one of the sub 
frames loads a page into the other frame of the frameset.
Assignee: rods → pollmann

Comment 4

18 years ago
Created attachment 15431 [details]
save attachment as testcase.zip

Comment 5

18 years ago
*spam*

adding crash keyword...
Keywords: crash

Comment 6

18 years ago
Updating QA contact.
QA Contact: ckritzer → vladimire

Comment 7

17 years ago
The content is appearing fine in the preview frame on windows 98 build 
2000-09-30-08-MN6 and Linux RedHat6.2 build 2000-10-03-09-MN6, but pressing 
print does crash on both of these builds. Switching OS to all.
OS: Windows NT → All
(Reporter)

Comment 8

17 years ago
Nominating for RTM since this crashes HP functionality related to the HP Print 
Dialog contract.
Keywords: rtm

Comment 9

17 years ago
I tried using the PR3 release and was successfully able to both preview and 
print on my NT 4 box.  I have not been able to test on W95, W98 or W2K.
(Reporter)

Comment 10

17 years ago
I have an NT box and it's crashing when I print.  However, it's not a fresh 
machine since I have over 6 or so versions of Netscape 6 betas on my machine.  

Valadimire - Please test and confirm "worksforme" on Win32 platforms.

Comment 11

17 years ago
Tested build 2000-10-06-09-MN6 on Windows 98,NT,and 2000.
Tested build 2000-10-05-09-MN6 on Linux RedHat6.2.
All crash...
Still a bug, sorry ;)
Marking [rtm need info]
Priority: P3 → P1
Whiteboard: [rtm need info]
With 10/10/2000 build on WINNT it previews correctly and prints without crashing.
Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 14

17 years ago
I tested on Win98 and Mac OS8.6 build 2000-10-20-08-MN6 and got no crash,
but Linux RedHat6.2 build 2000-10-20-09-MN6 still crashes... Reopening, changing 
OS to Linux
Status: RESOLVED → REOPENED
OS: All → Linux
Resolution: WORKSFORME → ---
Waqar, can you look at this on Linux?
Assignee: pollmann → waqar
Status: REOPENED → NEW

Comment 16

17 years ago
FWIW, this does not crash for me on FreeBSD branch commercial build from 10/17.
 Has anyone been able to grab a stack trace from one of these crashes?
vladimire@netscape.com could you try the latest build on Linux and see if it
still crashes? thanks. (There have been a number of fixes for crashers checked
in recently that may have fixed this problem.)

Comment 18

17 years ago
Still crashing on RedHat6.2 build 2000-10-25-09-MN6..

Comment 19

17 years ago
I got web content in the HP print dialog and
I was able to print this from:
  the 2000.10.25 MN6 build
  my Linux 6.2 branch build (built 10/25).

Comment 20

17 years ago
This sounds a lot like bug 54004 - intermitent crash printing out a document
containing frames or iframes.  Since there are no stack traces here, and lots of
analysis has happend on 54004, I'm marking this a duplicate.


*** This bug has been marked as a duplicate of 54004 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 21

17 years ago
Are we 100% convinced that this really is a duplicate defect?  I hope that the 
specific problem (and sample URL) specified by this defect will continue to be 
verified, as you address the other defect.

Comment 22

17 years ago
Verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.