Open Bug 534602 Opened 10 years ago Updated 6 days ago

autosyncActivities ERROR onDownloadCompleted: TypeError: this._syncInfoPerFolder[folder.URI] is undefined

Categories

(MailNews Core :: Backend, defect)

1.9.1 Branch
x86
macOS
defect
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: Usul, Unassigned)

Details

UNCO as I don't have any STRs,

I caught the following in my Error console :
Error: this._syncInfoPerFolder[folder.URI] is undefined
Source File: file:///Applications/Thunderbird.app/Contents/MacOS/modules/activity/autosync.js
Line: 337
On top of this I now have another error message : 
2010-02-22 20:13:35	autosyncActivities	ERROR	onDownloadCompleted: TypeError: this._syncInfoPerFolder[folder.URI] is undefined

Turning to new as I'm seeing the issue again.
Status: UNCONFIRMED → NEW
Ever confirmed: true
With my new experience on Ubuntu 10.04
    OSinfo : Linux(x86-gcc3)
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1 (rc2)
I have the following error:

Error: this._syncInfoPerFolder[folder.URI] is undefined
Source file: file:///usr/local/thunderbird/modules/activity/autosync.js
Line: 337

That line has :
let process = this._syncInfoPerFolder[folder.URI].activity; 

Actually I've no idea which action triggered that error
Günter how would you feel about running with ImapAutoSync:5 and try to reproduce ?
Same on my system:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.12) Gecko/20101027 Lightning/1.0b2 Thunderbird/3.1.6 ThunderBrowse/3.3.4

Debian 32 bit testing

3 pop and 2 IMAP account configured

Seems not to impact me but error console shows the above error message
Hello,

I can confirm that problem exist also under FreeBSD 9.0 AMD64
Saw this same issue on Thunderbird 3.1.9

Error: this._syncInfoPerFolder[folder.URI] is undefined
Source File: file:///E:/Program%20Files/Mozilla%20Thunderbird/modules/activity/autosync.js
Line: 337

Thunderbird can no longer download any emails from our IMAP mail server. It can show the number of new mails only.

No changes done to the system since it was last working.

Running on Windows XP Home SP3.
I'm seeing it as well on 5.0b2 

Error: this._syncInfoPerFolder[folder.URI] is undefined
Source File: resource:///modules/activity/autosync.js
Line: 337

The only behavior I'm having problem with is Spotlight search, Bug #670566
Still see this?
Flags: needinfo?(mitra_lists)
No, no such err anymore.
Running Ubuntu 12.04
  Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Thunderbird/33.0a2 (en-US)

6 IMAP accounts, one of them is gmail.
Confirmed, I'm not seeing it either.
Flags: needinfo?(mitra_lists)
Thanks guys
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
I'm seeing this lately in a local build:

autosyncActivities      ERROR   onDownloadCompleted: TypeError: this._syncInfoPerFolder.get(...) is undefined
JavaScript error: resource:///modules/activity/autosync.js, line 309: TypeError: this._syncInfoPerFolder.get(...) is undefined

Not easy to reproduce or predict.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.