Closed Bug 534701 Opened 10 years ago Closed 10 years ago

Fix up comm-central bustages that are a result of the electrolysis landing.

Categories

(Firefox Build System :: General, defect, blocker)

defect
Not set
blocker

Tracking

(status1.9.2 .4-fixed)

RESOLVED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- .4-fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: verified1.9.2, Whiteboard: [fixed-lorentz])

Attachments

(2 files, 1 obsolete file)

There's two bustages that I know of currently:

1) crashreporter failing to build in tests - this actually breaks all non-libxul builds which have --enable-tests:

nsTestCrasher.o: In function `nsTestCrasher::LockDir(nsILocalFile*, nsISupports**)':
/buildbot/linux-comm-central-check/build/mozilla/toolkit/crashreporter/test/nsTestCrasher.cpp:35: undefined reference to `XRE_LockProfileDirectory'
collect2: ld returned 1 exit status

I have a patch for this.

2) Static builds of comm-central + mozilla-central failing due to:

ccache /tools/gcc-4.1.1/bin/g++ -o thunderbird-bin  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -gstabs+ -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -Os -freorder-blocks -fno-reorder-functions -finline-limit=50  nsMailApp.o nsStaticComponents.o    -lpthread   -Wl,-rpath-link,/buildbot/comm-central-trunk-linux/build/objdir-tb/mozilla/dist/bin:/usr/lib:/usr/local/lib:/lib -Wl,-rpath-link,/usr/local/lib  -L../../mozilla/dist/bin -L../../mozilla/dist/lib ../../mozilla/toolkit/xre/libxulapp_s.a -L../../mozilla/staticlib -L/buildbot/comm-central-trunk-linux/build/objdir-tb/mozilla/dist/bin -lmozjs  -L/buildbot/comm-central-trunk-linux/build/objdir-tb/mozilla/dist/bin -lxpcom -lxpcom_core  `/buildbot/comm-central-trunk-linux/build/objdir-tb/mozilla/dist/bin/nspr-config --prefix=/buildbot/comm-central-trunk-linux/build/objdir-tb/mozilla/dist --libdir=/buildbot/comm-central-trunk-linux/build/objdir-tb/mozilla/dist/lib --libs` -L/lib -lgtk-x11-2.0 -latk-1.0 -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0      -lX11  -L/lib -ldbus-glib-1 -ldbus-1 -lglib-2.0   -Wl,--whole-archive -ljemalloc -Wl,--no-whole-archive -ldl -lm  ../../mozilla/staticlib/components/libpref.a ../../mozilla/staticlib/components/libuconv.a ../../mozilla/staticlib/components/libucvmath.a ../../mozilla/staticlib/components/libi18n.a ../../mozilla/staticlib/components/libnecko.a ../../mozilla/staticlib/components/libauth.a ../../mozilla/staticlib/components/libxpconnect.a ../../mozilla/staticlib/components/libjsctypes.a ../../mozilla/staticlib/components/libchardet.a ../../mozilla/staticlib/components/libzipwriter.a ../../mozilla/staticlib/components/libjar50.a ../../mozilla/staticlib/components/libmork.a ../../mozilla/staticlib/components/libcookie.a ../../mozilla/staticlib/components/libpermissions.a ../../mozilla/staticlib/components/libstoragecomps.a ../../mozilla/staticlib/components/librdf.a ../../mozilla/staticlib/components/libcaps.a ../../mozilla/staticlib/components/libhtmlpars.a ../../mozilla/staticlib/components/libgkgfxthebes.a ../../mozilla/staticlib/components/libimglib2.a ../../mozilla/staticlib/components/libgkplugin.a ../../mozilla/staticlib/components/libwidget_gtk2.a ../../mozilla/staticlib/components/libtxmgr.a ../../mozilla/staticlib/components/libcomposer.a ../../mozilla/staticlib/components/libgklayout.a ../../mozilla/staticlib/components/libdocshell.a ../../mozilla/staticlib/components/libembedcomponents.a ../../mozilla/staticlib/components/libwebbrwsr.a ../../mozilla/staticlib/components/libnsappshell.a ../../mozilla/staticlib/components/libuniversalchardet.a ../../mozilla/staticlib/components/libaccessibility.a ../../mozilla/staticlib/components/libchrome.a ../../mozilla/staticlib/components/libmozfind.a ../../mozilla/staticlib/components/libintlapp.a ../../mozilla/staticlib/components/libwindowds.a ../../mozilla/staticlib/components/libxpautocomplete.a ../../mozilla/staticlib/components/libappcomps.a ../../mozilla/staticlib/components/libremoteservice.a ../../mozilla/staticlib/components/libfileview.a ../../mozilla/staticlib/components/libcommandlines.a ../../mozilla/staticlib/components/libsatchel.a ../../mozilla/staticlib/components/libtkautocomplete.a ../../mozilla/staticlib/components/libtoolkitcomps.a ../../mozilla/staticlib/components/libspellchecker.a ../../mozilla/staticlib/components/libunixproxy.a ../../mozilla/staticlib/components/libpipboot.a ../../mozilla/staticlib/components/libpipnss.a ../../mozilla/staticlib/components/libpippki.a ../../mozilla/staticlib/components/libautoconfig.a ../../mozilla/staticlib/components/libsystem-pref.a ../../mozilla/staticlib/components/libmozldap.a ../../mozilla/staticlib/components/libmsgsmime.a ../../mozilla/staticlib/components/libimport.a ../../mozilla/staticlib/components/libmail.a ../../mozilla/staticlib/components/libmailcomps.a ../../mozilla/staticlib/libmozreg_s.a ../../mozilla/staticlib/libunicharutil_s.a ../../mozilla/staticlib/libucvutil_s.a ../../mozilla/staticlib/libgtkxtbin.a ../../mozilla/staticlib/libthebes.a ../../mozilla/staticlib/libgfxpsshar.a ../../mozilla/staticlib/libgkgfx.a ../../mozilla/staticlib/libmimecthglue_s.a  -L../../mozilla/modules/libimg/png -lmozpng -L../../mozilla/jpeg -lmozjpeg -L../../mozilla/modules/zlib/src -lmozz  -L../../mozilla/dist/bin -L../../mozilla/dist/lib -lcrmf -lsmime3 -lssl3 -lnss3 -lnssutil3 -lsoftokn3  -L../../mozilla/dist/bin -L../../mozilla/dist/lib -lldap60 -lprldap60 -lldif60  ../../mozilla/gfx/cairo/cairo/src/libmozcairo.a ../../mozilla/gfx/cairo/libpixman/src/libmozlibpixman.a   -lXrender -lfreetype -lfontconfig ../../mozilla/gfx/qcms/libmozqcms.a  -lXt -lgthread-2.0 -L/lib -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   -L../../mozilla/dist/lib -lsqlite3 -lasound      
../../mozilla/toolkit/xre/libxulapp_s.a(nsAppRunner.o): In function `nsXULAppInfo::GetProcessType(unsigned int*)':
/buildbot/comm-central-trunk-linux/build/mozilla/toolkit/xre/nsAppRunner.cpp:741: undefined reference to `XRE_GetProcessType'
../../mozilla/toolkit/xre/libxulapp_s.a(nsAppRunner.o): In function `XRE_main':
/buildbot/comm-central-trunk-linux/build/mozilla/toolkit/xre/nsAppRunner.cpp:3653: undefined reference to `XRE_DeinitCommandLine'
/buildbot/comm-central-trunk-linux/build/mozilla/toolkit/xre/nsAppRunner.cpp:3049: undefined reference to `XRE_InitCommandLine'

This is a result of nsEmbedComponents.cpp being built for non-static-builds only. Again I have a patch (but not reviewed).
The first one is unrelated to e10s, it's from Ted's crashreporter push immediately prior.
This patch has r=ted over irc. As the tree is restricted and no-one wants to give me approval to land, or even a timescale, I've given up for today.

If someone can get approval or land it just after the tree opens, please do. It would be nice to get an idea of some state for our unit & leak tests before too many other patches land.
Attachment #417541 - Flags: review+
Attached patch Static build fix (obsolete) — Splinter Review
This fixes the static builds on my Mac - moves the undefined functions from the not built on static builds nsEmbedFunctions.cpp to the built nsAppRunner.cpp.
Attachment #417544 - Flags: review?
Attachment #417544 - Flags: review? → review?(benjamin)
(In reply to comment #1)
> The first one is unrelated to e10s, it's from Ted's crashreporter push
> immediately prior.

Correct, sorry I forgot that.
Comment on attachment 417544 [details] [diff] [review]
Static build fix

I suspect this won't build without additional #includes, but I'll fix it up in a bit.
Attachment #417560 - Flags: review?(jones.chris.g)
Comment on attachment 417560 [details] [diff] [review]
Static build fix, rev. 2 [checked in]

>diff --git a/toolkit/xre/nsAppRunner.h b/toolkit/xre/nsAppRunner.h
>--- a/toolkit/xre/nsAppRunner.h
>+++ b/toolkit/xre/nsAppRunner.h
>@@ -177,9 +177,17 @@ void SetAllocatedString(const char *&str
> template<class T>
> void SetStrongPtr(T *&ptr, T* newvalue)
> {
>   NS_IF_RELEASE(ptr);
>   ptr = newvalue;
>   NS_IF_ADDREF(ptr);
> }
> 
>+#ifdef MOZ_IPC
>+namespace mozilla {
>+namespace startup {
>+extern GeckoProcessType sChildProcessType;
>+}
>+}

I don't understand what the "startup" namespace is supposed to mean.  Why not mozilla::sChildProcessType?  Also this variable should be named |sProcessType| now, but that doesn't really fall under this bug.
Attachment #417560 - Flags: review?(jones.chris.g) → review+
Attachment #417541 - Attachment description: Non-libxul/enable tests fix (r=ted over irc) → Non-libxul/enable tests fix (r=ted over irc) [checked in]
Comment on attachment 417541 [details] [diff] [review]
Non-libxul/enable tests fix (r=ted over irc) [checked in]

http://hg.mozilla.org/mozilla-central/rev/7ca38481c7ae
Comment on attachment 417560 [details] [diff] [review]
Static build fix, rev. 2 [checked in]

http://hg.mozilla.org/mozilla-central/rev/60937d3bcc2a
Attachment #417560 - Attachment description: Static build fix, rev. 2 → Static build fix, rev. 2 [checked in]
Duplicate of this bug: 534779
Attachment #417544 - Attachment is obsolete: true
Attachment #417544 - Flags: review?(benjamin)
Target Milestone: --- → mozilla1.9.3a1
Version: unspecified → Trunk
This all seems to be fixed now. Thanks to Phil for landing, and Benjamin for fixing up the static build patch.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Blanket approval for Lorentz merge to mozilla-1.9.2
a=beltzner for 1.9.2.4 - please make sure to mark status1.9.2:.4-fixed
Verified for 1.9.2 since this is all fine on the 1.9.2 branch.
Keywords: verified1.9.2
Blocks: 573523
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.