Mozilla optimized bits crash on startup

VERIFIED FIXED in M18

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Simon Fraser, Assigned: Dan M)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I'm seeing a crash on startup of installed Mozilla bits, with the stack:

  00000000    PPC  1F438734  
  09948800    PPC  1F423070  main+00130
  099487A0    PPC  1F4224D8  main1(int, char**, nsISupports*)+00A38
  099484C0    PPC  1F3F90C8  nsAppShellService::Run()+00018
  09948480    PPC  1B0EA9B8  nsAppShell::Run()+00048
  09948430    PPC  1B0EB0F4  nsMacMessagePump::DoMessagePump()+0003C
  099483E0    PPC  1B0EB6A8  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00114
  09948390    PPC  1B0EC0DC  nsMacMessagePump::DoMouseMove(EventRecord&)+00074

danm changed that code recently; the line is

	if (!::EmptyRgn(((WindowRecord *) whichWindow)->contRgn))
		DispatchOSEventToRaptor(anEvent, whichWindow);

and it will crash when whichWindow is null.

I think we need another null check in there.
(Assignee)

Comment 1

18 years ago
Bummer! OK, I just checked in the extra null check. Can't hurt. I'm not seeing 
this crash, so I'm calling it fixed on faith.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Target Milestone: --- → M18
(Assignee)

Comment 2

18 years ago
*** Bug 53439 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

18 years ago
*** Bug 53391 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
Not getting this crash in current branch bits. marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.