IPC should use common setup for third_party files

RESOLVED DUPLICATE of bug 560615

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 560615
8 years ago
7 years ago

People

(Reporter: Takanori MATSUURA, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ja; rv:1.9.3a1pre) Gecko/20091214 Fedora/3.7a1pre-0.a1pre.2009121410.fc12 Minefield/3.7a1pre
Build Identifier: 

Generally, mozilla use nspr and nss which is included in source tarball or system ones (--with-system-nss/nspr with top configure script).

But ipc/chromium/src/base/basictypes.h which is included by xpcom/build/nsXPComInit.cpp tries to include "nspr/prtypes.h".  When I use "--with-system-nspr" with top configure script, the compilation of nsXPComInit.cpp is failed.

I think IPC should use nspr and nss not in ipc/chromium/src/base/third_party but selected by top configure script.

I suppose IPC suould use purify sources not in ipc/chromium/src/base/third_party but in xpcom/base.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 478976
(Reporter)

Comment 1

7 years ago
Created attachment 443864 [details] [diff] [review]
NSPR part of fix

Same manner of fix as bug560615.

Chris, can you review this?
Attachment #443864 - Flags: review?(jones.chris.g)
Comment on attachment 443864 [details] [diff] [review]
NSPR part of fix

bent is a better reviewer of this patch, he's dug around in this code.  I think chromium modified its NSPR, and I'm not sure it's compatible with our version/the system version.
Attachment #443864 - Flags: review?(jones.chris.g) → review?(bent.mozilla)
Comment on attachment 443864 [details] [diff] [review]
NSPR part of fix

Chromium has a modified version in there, yeah. I'm not sure it's worth trying to fix either. I'd recommend WONTFIX until we remove the chromium stuff entirely rather than hacking it more, but I'll let bsmedberg decide.
Attachment #443864 - Flags: review?(bent.mozilla) → review?(benjamin)

Comment 4

7 years ago
Isn't this a dup of bug 560615?
No, this is about using --with-system-nspr and excluding chromium's modified version.

Comment 6

7 years ago
But... it so much looks like that bug is about the same thing.

Updated

7 years ago
Attachment #443864 - Flags: review?(benjamin) → review?(bent.mozilla)
Actually, I think I'm crazy. Takanori, do you still have this problem now that the fix for bug 560615 has landed?
(Reporter)

Comment 8

7 years ago
No problem now.
Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 560615
Attachment #443864 - Flags: review?(bent.mozilla)
You need to log in before you can comment on or make changes to this bug.