Bugzilla interface is very slow when a user is in hundreds of groups

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Fida, Unassigned)

Tracking

({perf})

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009020911 Ubuntu/8.04 (hardy) Firefox/3.0.6
Build Identifier: 3.0.4

Hello

I'm using bugzilla 3.0.4 with postgresql 8.2 under ubuntu 8.0.4.
I noticed that when a user is a member of many products (about 300 ) (and groups (about 830)),
accessing to interface become verry slow (20 s after the request of
showing bug, adding new bug, etc...).
I've tested whith a user account member of more than 400 products

is it normal.
How could i fix this ?

Thanks 

Reproducible: Always

Steps to Reproduce:
1.Add a user to more than 800 groups
2.connect using this user account
3.trying to add new bug
Actual Results:  
we have to wait more than 20 s to access the home page , the editbug.cgi page, etc. every bugzillla pages that we have to load a user profile using the sub in_groups. 


it's a problem in all pages.
All pages that contain "my $user = Bugzilla->login(LOGIN_OPTIONAL)";

When i look into bugzilla perl libs, i see that the sub in_group (into
Bugzilla::User lib) which is take a lot of time.

The sql request search the group in all user groups. i don't
understand why it don't search only if user have access to group.

We have more than 700 products and 4 groups per product.

We see the slow when user with more than 800 groups try to access on
perhaps all bugzilla pages where we have to load user profile
(index.cgi, enter_bug.cgi....)

Thanks

Comment 1

8 years ago
Bugzilla 3.0.4 is pretty old now. There has been many performance improvements since Bugzilla 3.2. You should upgrade to Bugzilla 3.4.4 and see if your problem goes away.
Severity: critical → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 3.0.4
Duplicate of bug: 372795
(Reporter)

Comment 2

8 years ago
I've tried to migrate database from bugzilla 3.04 to bugzilla 3.4.4

I found a problem when user is a member of many groups (the example is
about a user who is member of 830 groups )

when i try to edit this user i get this error  (in the url
editusers.cgi?action=edit&userid=23)

Not an ARRAY reference at Bugzilla/Object.pm line 239, <DATA> line
228.

i didn't get this error for other users.
(Reporter)

Comment 3

8 years ago
Also, mu bug is about groups not products.
(Reporter)

Comment 4

8 years ago
the problem is still occured

i  have also this error log on syslog when it happens
(when i try to edit the user member of more than 500 groups)

kernel: [1647035.898883] editusers.cgi[29325]: segfault at e87d0f8d6 rip 7fbef097b102 rsp 7ffff8e38080 error 4
(Reporter)

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

8 years ago
(In reply to comment #4)
> kernel: [1647035.898883] editusers.cgi[29325]: segfault at e87d0f8d6 rip
> 7fbef097b102 rsp 7ffff8e38080 error 4

  Please attach (as an attachment, **not a comment**), the output of checksetup.pl for your Bugzilla.

Updated

8 years ago
Summary: Bugzilla interface is verry slow → Bugzilla interface is very slow when a user is in hundreds of groups
(Reporter)

Comment 6

8 years ago
Created attachment 418144 [details]
Migration from 3.0.4 to 3.4.4: checksetup.pl resuly

checksetup result
(Reporter)

Comment 7

8 years ago
Created attachment 418149 [details]
PostgresLOG : 

line 513 show the postgresql instruction when i try to edit this user

Updated

8 years ago
Attachment #418144 - Attachment mime type: application/octet-stream → text/plain

Updated

8 years ago
Attachment #418149 - Attachment mime type: application/octet-stream → text/plain

Comment 8

8 years ago
(In reply to comment #2)
> when i try to edit this user i get this error  (in the url
> editusers.cgi?action=edit&userid=23)
> 
> Not an ARRAY reference at Bugzilla/Object.pm line 239, <DATA> line
> 228.

  Okay, would you file that as a separate bug? I should have asked you to do that before, I'm sorry. Include all the info you just attached, on that bug, and link to that bug from here.
(Reporter)

Comment 9

8 years ago
Ok 
thanks

The new bug is Bug 536190
(Reporter)

Comment 10

8 years ago
Bugzilla 3.4.4 still verry slow after fixing the bug described under the comment 7
I've updating version of postgresql (now it is 8.4)
And the version of BDB::Pg (2.16.1)
Severity: major → critical
Version: 3.0.4 → 3.4.4

Comment 11

8 years ago
This bug is not critical, because it's very rare, in terms of all Bugzilla installations, for a user to be in hundreds of groups.
Severity: critical → major

Updated

8 years ago
Keywords: perf

Comment 12

8 years ago
  I just tested this on trunk with an enormously complex groups system (millions of rows in user_group_map, thousands of groups that all had a very involved group inheritance structure, all options on every bug, and the logged-in user being a member of over 1000 groups) and there's no visible slowdown whatsoever.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.