Page renders fine on screen, but is cut of in print or print preview

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: frank.vandamme, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091109 Linux Mint/8 (Helena) Shiretoko/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091109 Linux Mint/8 (Helena) Shiretoko/3.5.5

It's pretty simple - firefox prints roughly half the text and stops with a bar at the bottom of the screen. This has a fixed (relative?) position so I think that must be the problem. See the url. The page won't stay up forever (it's a job vacancy) but I'll include a tarbal of the page captured with Scrapbook (gives same result, I've tested). 

Reproducible: Always

Steps to Reproduce:
1. open url
2. go to print preview or print to a PS or PDF file or to paper.
(Reporter)

Comment 1

9 years ago
Created attachment 417677 [details]
Tarbal of web page yielding problems
(Reporter)

Comment 2

9 years ago
Created attachment 417678 [details]
printed web page in case to a postscript file
http://css-seeker.newjobs.com/r/BEDU/v3.4.1.52/jobviewapply/ApplyConsole_css.axd

html, body{
	margin: 0 !important;
	padding: 0 !important;
	height: 100% !important;
	overflow: hidden !important;
}

...

@media print
{
div#monsterAppliesPageWrapper {overflow:visible !important;}
}
@media screen
{
div#monsterAppliesPageWrapper {overflow:auto !important;}
}

=====================

The scrollbar you see on screen is for the div#monsterAppliesPageWrapper.
In print mode, "overflow:visible" is specified, but since overflow is
hidden for html,body the overflow is not displayed.

Adding the following rule to the "@media print" rule may give the
desired result:
  html, body { overflow:visible !important; }
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.