If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mail/News window of TB always opens in the background, but the menu bar is in the foreground

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
8 years ago
a year ago

People

(Reporter: Rotis, Unassigned)

Tracking

({polish, regression})

x86
Mac OS X
polish, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

When starting Thunderbird it always opens the main window (Mail & Newsgroups) in the background behind all other open windows od other programs, but the menu bar clearly states 'Thunderbird' in the foreground. To access the main window I must select another program and return to Thunderbird. Then its window is in the foreground.

When there is no open window of any kind, TB still always opens its main window in the backgroud greyed out. (See image for better understanding)

Reproducible: Always

Steps to Reproduce:
1.Start TB.
2.Main window opens in background behind all other open windows


Expected Results:  
Expected: TB's main window opens as the first window in the foreground like it is in any other program.
(Reporter)

Comment 1

8 years ago
Created attachment 417692 [details]
TB's start window always opens behind all other windows
(In reply to comment #0)

> Steps to Reproduce:
> 1.Start TB.

How do you start it ? When I start TB from the dock - it pops up in the foreground on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0 10.5.8.

Do you have the same issue if you start Thunderbird in -safe-mode(http://kb.mozillazine.org/Safe_mode) ?

Jay is this a 10.6 only issue ?
(Reporter)

Comment 3

8 years ago
When I start from the Dock it is in the background. When I start it in Safe Mode via Terminal also.
CONFIRMED and marking as NEW.

It has been this way since before 10.6 too. I definitely saw it in 10.5. I think it was fixed briefly before with the multi-password prompt and serialized password work. IIRC there was a time when there had been one fix for the multi-password prompt that actually made everything work (including bringing Thunderbird to the Foreground after launch), but then some other work regressed the multi-password prompt problem and I seem to remember it could no longer be fixed in the same way, and once it was re-fixed, the new method Thunderbird started in the background again.

Everything reported is accurate in regards to being in the background though the Thunderbird Menubar is the active Menubar. A few more details are that if there are multiple windows open Thunderbird will become the penultimate window on the stack of windows. It will not steal focus from whatever window was the active window, but it will cover any other windows up. If using the Master Password manager, then the Master Password prompt WILL come to the TOP most window position, however it will NOT have focus and you have to click in the password box to get a cursor. The MAIN Thunderbird window however will remain UNDER whatever was in the foreground when starting, even with the Password Manager on top, but without focus.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 534683
rotis, Jay, do you still see this in version 3.1?

It seems like this would be fairly irritating
Keywords: polish, regression
Version: unspecified → 3.0
Leho, do you still see this on a Mac?
Flags: needinfo?(leho)
Whiteboard: [closeme 2016-06-15]
Mac is not my active OS anymore, so can't really tell for sure.
Flags: needinfo?(leho)
(Thanks Leho)

James, do you see this on a Mac
Flags: needinfo?(jamesrome)

Comment 10

a year ago
I do not see this on my Mac. but I first get the password popup before the main window appears.
Flags: needinfo?(jamesrome)

Comment 11

a year ago
Resolved per whiteboard and Comment 10
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2016-06-15]
You need to log in before you can comment on or make changes to this bug.