CalDAV calendar with caching enabled does not update correctly

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: jurekraben, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; de-de) AppleWebKit/532.7+ (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.1.5) Gecko/20091214 Lightning/1.0b2pre Shredder/3.0.1pre

If you add a calendar and enable experimental caching, the calendar will not be updated correctly. If you change change/add/remove an event from another computer to the caldav calendar and restart Shredder/Lightning on the first computer, the calendar will not display the new events, even if you wait for sync...

Reproducible: Always

Steps to Reproduce:
1. Add a caldav calendar on two computers with caching enabled
2. Add an event on one computer
3. Restart calendar on both computers or right click "reload" on the calendars
Actual Results:  
Only the computer where the calendar was changed will display the new event

Expected Results:  
Both computers should display the new event.

Seems to be a logical error. Also the cached calendar should ask the server for differences after displaying the cached information...
Jurek, does this still happen with the latest 1.0b2pre nightlies?

Comment 2

8 years ago
no response to questions in previous comment, so => incomplete.
if you still see the problem in the newest version, please comment in the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.