Status

()

P3
normal
VERIFIED INVALID
19 years ago
18 years ago

People

(Reporter: jband_mozilla, Assigned: dcone)

Tracking

Trunk
mozilla0.9.3
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Purify shows a UMR (uninitialied memory read) in a call to StretchDIBits. It 
shows the alloc'd block to be the mImageBits. So, I assume, there are cases 
where not all bytes in the pixel data buffer get written. This may be harmless. 
I don't know - But StretchDIBits is actually trying to read the byte, so this is 
suspect.

Sorry I don't have a URL - I was running under the browser buster.

I'll attach the purify trace.
(Reporter)

Comment 1

19 years ago
Created attachment 15187 [details]
Purify trace of error location

Comment 2

19 years ago
> rendering
Assignee: pnunn → kmcclusk
Don, here's one for you.
Assignee: kmcclusk → dcone
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 4

19 years ago
Updating QA Contact
QA Contact: paw → tpreston
(Assignee)

Updated

19 years ago
Target Milestone: --- → Future
(Assignee)

Comment 5

18 years ago
I dont think this is happening anymore.. that line has been fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
I'm sure don is good with his word, therefore I am verifying ;-)
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
reopening bug; I"m seeing this again (perhaps due to new imglib?)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Target Milestone: Future → ---
Target Milestone: --- → mozilla0.9.3
(Assignee)

Comment 8

18 years ago
This is true, there can be uninitialized bits on an incremental load but we do 
limit this drawn area so the garbabe is not drawn.  This UMR in StretchDIBits is 
happening.. but is not really a bug because we do this by design.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID

Comment 9

18 years ago
Since this is done by design, I am marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.