pageMods has incorrect doc for iframes

RESOLVED DUPLICATE of bug 543526

Status

Mozilla Labs
Jetpack Prototype
--
major
RESOLVED DUPLICATE of bug 543526
8 years ago
8 years ago

People

(Reporter: Morgan 'ARR!' Allen, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4 XPCOMViewer/0.9a
Build Identifier: 

pageMods fires callbacks with this.contentDocument from onReady. If the match was triggered by an iframe, this.contentDocument is still the content document of the tab, not the iframe.

Reproducible: Always

Actual Results:  
doc is always the main tab document in callback

Expected Results:  
iframes are passed to callback
(Reporter)

Comment 1

8 years ago
Created attachment 417804 [details] [diff] [review]
pageMod iframe fix

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543526
You need to log in before you can comment on or make changes to this bug.