If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Continuously re-downloads the same messages via IMAP from Microsoft Exchange

RESOLVED DUPLICATE of bug 534835

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED DUPLICATE of bug 534835
8 years ago
8 years ago

People

(Reporter: cove_s, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.15) Gecko/2009101601 Firefox/3.0.15 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0 RC 3

Continuously re-downloads the same messages via IMAP from Microsoft Exchange via IMAP rather than only downloading updates to the IMAP folders. 

Environment observed with:
Server: Microsoft Exchange (via IMAP) 2003, 2007 and 14
Client OSs: Window Vista 64bit, CentOS 5.3 64bit
Thunderbird versions: 3.0 (under CentOS 5.3), 3.0 RC3 (under Windows Vista 64bit)


Reproducible: Always

Steps to Reproduce:
1.Setup IMAP account on Microsoft Exchange 2003, 2007 or 14.
2.Populate inbox w/ 6300 messages (6300=current case, may not be relevant though)
3.Configure Thunderbird to connect to download messages, including the full body for indexing.
Actual Results:  
Thunderbird downloads the messages in the inbox, and other folders, repeatedly. At some point it does appear to stop for a while, though reports are vague; from 2hrs to 1 day, the repeated downloading eventually stops.

Expected Results:  
Messages are downloaded once, and only updates to inbox (or other folders) are downloaded.

Example session:
* OK The Microsoft Exchange IMAP4 service is ready. Welcome to E14 beta IMAP server.
1 capability
* CAPABILITY IMAP4 IMAP4rev1 AUTH=GSSAPI AUTH=PLAIN STARTTLS IDLE NAMESPACE LITERAL+
1 OK CAPABILITY completed.
2 authenticate plain
+
[login credentials]
2 OK AUTHENTICATE completed.
3 namespace
* NAMESPACE (("" "/")) NIL NIL
3 OK NAMESPACE completed.
4 lsub "" "*"
* LSUB () "/" Calendar
* LSUB () "/" Contacts
* LSUB () "/" Contacts1
* LSUB () "/" Drafts
* LSUB () "/" "Deleted Items"
* LSUB () "/" INBOX
* LSUB () "/" Journal
* LSUB () "/" "Junk E-mail"
* LSUB () "/" Notes
* LSUB () "/" "RSS Subscriptions"
* LSUB () "/" Outbox
* LSUB () "/" Sent
* LSUB () "/" "Sent Items"
* LSUB () "/" "Sync Issues"
* LSUB () "/" Tasks
* LSUB () "/" Trash
* LSUB () "/" quarantine
* LSUB () "/" INBOX/2007
* LSUB () "/" INBOX/2008
[cut]
4 OK LSUB completed.
5 list "" "INBOX"
* LIST (\Marked \HasChildren) "/" INBOX
5 OK LIST completed.
6 select "INBOX"
* 25899 EXISTS
* 0 RECENT
* FLAGS (\Seen \Answered \Flagged \Deleted \Draft $MDNSent)
* OK [PERMANENTFLAGS (\Seen \Answered \Flagged \Deleted \Draft $MDNSent)] Permanent flags
* OK [UNSEEN 7] Is the first unseen message
* OK [UIDVALIDITY 962] UIDVALIDITY value
* OK [UIDNEXT 1082414] The next unique identifier value
6 OK [READ-WRITE] SELECT completed.
7 UID fetch 1:* (FLAGS)
* 1 FETCH (FLAGS (\Seen) UID 774804)
* 2 FETCH (FLAGS (\Seen) UID 780676)
* 3 FETCH (FLAGS (\Seen) UID 780677)
* 4 FETCH (FLAGS (\Seen) UID 780678)
* 5 FETCH (FLAGS (\Seen) UID 780679)
* 6 FETCH (FLAGS (\Seen) UID 780680)
* 7 FETCH (FLAGS () UID 780681)
* 8 FETCH (FLAGS (\Seen) UID 780682)
[cut]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534835
You need to log in before you can comment on or make changes to this bug.