$.jsonp is not a function error on Plugin Check page

VERIFIED FIXED

Status

www.mozilla.org
General
--
critical
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: stephend, Assigned: ozten)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [3.6Br5][1.9.2-fixed], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I'm using Firefox 3.5.5 with Shockwave Flash 10.0 r42, and http://www.mozilla.com/en-US/plugincheck/ is no longer working; instead, I get:

Error: $.jsonp is not a function
Source File: http://www.mozilla.com/js/plugincheck.js
Line: 17
(Reporter)

Comment 1

8 years ago
(Broken on staging too: http://www-trunk.stage.mozilla.com/en-US/plugincheck/.)

Updated

8 years ago
Whiteboard: [3.6Br5]
(Assignee)

Comment 2

8 years ago
Disabling all plugins and the page works.

Enabling any plugin and the page breaks on www-trunk.

Still working to identify the root cause.
My dev env works, trunk, authstage, and prod are broken.
(Assignee)

Comment 3

8 years ago
The updates made to mozilla.com/includes/min/groupsConfig.php break our copy of jquery-jsonp.
(Assignee)

Comment 4

8 years ago
Moving inclusion before our script appears to be a viable work-around.
Committing and testing on www-trunk.
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> Moving inclusion before our script appears to be a viable work-around.
> Committing and testing on www-trunk.

http://www-trunk.stage.mozilla.com/en-US/plugincheck/ now WFM, thanks!
(Assignee)

Comment 6

8 years ago
Trying to push en-US/plugincheck/index.html via Kubla.

It's failing to get to authstage on first attempt.

Comment 7

8 years ago
Probably should find another way to fix this. On trunk <script> is outside of <html> which breaks validation.

Comment 8

8 years ago
Created attachment 417853 [details] [diff] [review]
Fixes problem.

This is one way to fix it. Another way(probably better, but a larger change) would be to move jquery to the js group in groupsConfig.php and rip it out of plugincheck.js.

Updated

8 years ago
Attachment #417853 - Attachment is patch: true
Attachment #417853 - Attachment mime type: application/octet-stream → text/plain
(Assignee)

Comment 9

8 years ago
(In reply to comment #7)
Thanks for catching that.
(In reply to comment #8)
Yes, I want to rework the way jquery is included, but it will take longer and this page is in the middle of refactoring for L10n and web badge code. I'll back out my work and try to get it working w/o jquery inline instead of pushing a quick prod fix.
(Assignee)

Comment 10

8 years ago
On trunk is a version that validates. It uses the $extra_footers global variable to add JavaScript after the footer. This should be a suitable quick fix.

Still working on 
1) no jQuery version
2) conflict free jQuery version for web badge
(Assignee)

Comment 11

8 years ago
This is fixed in production. Keeping open to track the *real* fixes.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 535201
Flags: blocking-firefox3.6?

Comment 13

8 years ago
this is all server side, right?   if so then we could remove the blocking 3.6
(Assignee)

Comment 14

8 years ago
(In reply to comment #10)
#1 done and on www-trunk.

Using noConflict and grabbing jQuery into Pfs.$
(Assignee)

Comment 15

8 years ago
(In reply to comment #10)
#2 done and on www-trunk

plugincheck.js will depend on mozilla.com's jquery
plugincheck_badge.js will continue to include a copy of jquery.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

8 years ago
Verified FIXED on:

* http://www.mozilla.com/en-US/plugincheck/
* http://www-trunk.stage.mozilla.com/en-US/plugincheck/
Status: RESOLVED → VERIFIED
Flags: blocking-firefox3.6? → blocking-firefox3.6+
Whiteboard: [3.6Br5] → [3.6Br5][1.9.2-fixed]
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.