IETab Drag Bookmark downwards on bookmarktoolbar causes Firefox crash [@ mshtml.dll@0x17681b ] CInterfaceFromWindowProp::PrivDragDrop / nsDragService::StartInvokingDragSession

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: andi, Unassigned)

Tracking

({crash, crashreportid})

3.5 Branch
x86
Windows XP
crash, crashreportid
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

When dragging a bookmark from my bookmarktoolbar downwards, Firefox crashes. This is reproducible with several bookmarks (I didn't test all). If draqgging within a bookmarks-toolbar-folder the crash doesn't occur.

Reproducible: Always

Steps to Reproduce:
1. Drag a bookmark from bookmarkstoolbar
2. Drag upwards... no problem. Drag downwards... ---> Firefox crashes
(Reporter)

Comment 1

9 years ago
LOL... I restartet Firefox about 4 times before and the bug was reproducible always. With current start it doesn't occur any more. :o/

Firefox sent data via feedback agent. If I can provide additional data (coredumps?) please tell me.
Please read https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Version: unspecified → 3.5 Branch
(Reporter)

Comment 3

9 years ago
IDs from yesterday's crashes...
Crash ID: bp-b039a8c6-2e1d-4ef2-9f89-d1d382091216
Crash ID: bp-b331df74-4dcf-448c-a18a-2e0c62091216
Crash ID: bp-30034a18-341e-4380-83f5-38cdb2091216
Keywords: crash, crashreportid
Summary: Drag Bookmark downwards on bookmarktoolbar causes Firefox crash → Drag Bookmark downwards on bookmarktoolbar causes Firefox crash [@ mshtml.dll@0x17681b ]

Comment 4

9 years ago
Signature	mshtml.dll@0x17681b
UUID	b039a8c6-2e1d-4ef2-9f89-d1d382091216
Time 	2009-12-16 00:33:47.715777
Uptime	7
Last Crash	11 seconds before submission
Product	Firefox
Version	3.5.5
Build ID	20091102152451
Branch	1.9.1
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x24
User Comments	
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	mshtml.dll 	mshtml.dll@0x17681b 	
1 	mshtml.dll 	mshtml.dll@0x1a0986 	
2 	mshtml.dll 	mshtml.dll@0x98b12 	
3 	mshtml.dll 	mshtml.dll@0x989ae 	
4 	jscript.dll 	jscript.dll@0x229d6 	
5 	jscript.dll 	jscript.dll@0x22946 	
6 	jscript.dll 	jscript.dll@0x231e4 	
7 	jscript.dll 	jscript.dll@0x21c09 	
8 	jscript.dll 	jscript.dll@0x21210 	
9 	jscript.dll 	jscript.dll@0x211c5 	
10 	jscript.dll 	jscript.dll@0x22a58 	
11 	jscript.dll 	jscript.dll@0x21122 	
12 	jscript.dll 	jscript.dll@0x2144b 	
13 	jscript.dll 	jscript.dll@0x21b31 	
14 	jscript.dll 	jscript.dll@0x2420e 	
15 	jscript.dll 	jscript.dll@0x21210 	
16 	jscript.dll 	jscript.dll@0x211c5 	
17 	jscript.dll 	jscript.dll@0x22a58 	
18 	jscript.dll 	jscript.dll@0x21122 	
19 	jscript.dll 	jscript.dll@0x2144b 	
20 	jscript.dll 	jscript.dll@0x21b31 	
21 	jscript.dll 	jscript.dll@0x30ff5 	
22 	jscript.dll 	jscript.dll@0x241d4 	
23 	jscript.dll 	jscript.dll@0x2144b 	
24 	jscript.dll 	jscript.dll@0x21b31 	
25 	jscript.dll 	jscript.dll@0x2420e 	
26 	jscript.dll 	jscript.dll@0x21210 	
27 	jscript.dll 	jscript.dll@0x211c5 	
28 	jscript.dll 	jscript.dll@0x22a58 	
29 	jscript.dll 	jscript.dll@0x21122 	
30 	jscript.dll 	jscript.dll@0x2144b 	
31 	jscript.dll 	jscript.dll@0x21b31 	
32 	jscript.dll 	jscript.dll@0x33991 	
33 	jscript.dll 	jscript.dll@0x241d4 	
34 	jscript.dll 	jscript.dll@0x2144b 	
35 	jscript.dll 	jscript.dll@0x21b31 	
36 	jscript.dll 	jscript.dll@0x2420e 	
37 	jscript.dll 	jscript.dll@0x21210 	
38 	jscript.dll 	jscript.dll@0x211c5 	
39 	jscript.dll 	jscript.dll@0x22a58 	
40 	jscript.dll 	jscript.dll@0x21122 	
41 	jscript.dll 	jscript.dll@0x20f89 	
42 	jscript.dll 	jscript.dll@0x22641 	
43 	jscript.dll 	jscript.dll@0x224fd 	
44 	mshtml.dll 	mshtml.dll@0x1a3f48 	
45 	mshtml.dll 	mshtml.dll@0x111f2c 	
46 	mshtml.dll 	mshtml.dll@0x6d54d 	
47 	mshtml.dll 	mshtml.dll@0x6dfe5 	
48 	mshtml.dll 	mshtml.dll@0x8a1e4 	
49 	mshtml.dll 	mshtml.dll@0x8a7ac 	
50 	mshtml.dll 	mshtml.dll@0x1672af 	
51 	mshtml.dll 	mshtml.dll@0x18fa52 	
52 	mshtml.dll 	mshtml.dll@0x18f635 	
53 	mshtml.dll 	mshtml.dll@0x1ab9c2 	
54 	ole32.dll 	CInterfaceFromWindowProp::PrivDragDrop 	
55 	ole32.dll 	PrivDragDrop 	
56 	ole32.dll 	CDragOperation::GetDropTarget 	
57 	ole32.dll 	CDragOperation::UpdateTarget 	
58 	ole32.dll 	DoDragDrop 	
59 	xul.dll 	nsDragService::StartInvokingDragSession 	widget/src/windows/nsDragService.cpp:316
60 	xul.dll 	nsDragService::InvokeDragSession 	widget/src/windows/nsDragService.cpp:263
61 	xul.dll 	nsBaseDragService::InvokeDragSessionWithImage 	widget/src/xpwidgets/nsBaseDragService.cpp:276
62 	xul.dll 	nsEventStateManager::DoDefaultDragStart 	content/events/src/nsEventStateManager.cpp:2501
63 	xul.dll 	xul.dll@0x30cd17 	
64 	xul.dll 	nsEventStateManager::PreHandleEvent 	content/events/src/nsEventStateManager.cpp:997
65 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6313
66 	xul.dll 	PresShell::HandlePositionedEvent 	layout/base/nsPresShell.cpp:6211
67 	xul.dll 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6071
68 	xul.dll 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1400
69 	xul.dll 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1359
70 	xul.dll 	HandleEvent 	view/src/nsView.cpp:168
71 	xul.dll 	nsWindow::DispatchEvent 	widget/src/windows/nsWindow.cpp:1051
72 	xul.dll 	nsWindow::DispatchWindowEvent 	widget/src/windows/nsWindow.cpp:1071
73 	xul.dll 	nsWindow::DispatchMouseEvent 	widget/src/windows/nsWindow.cpp:6614
74 	xul.dll 	ChildWindow::DispatchMouseEvent 	widget/src/windows/nsWindow.cpp:6761
75 	xul.dll 	nsWindow::ProcessMessage 	widget/src/windows/nsWindow.cpp:4618
76 	xul.dll 	nsWindow::WindowProc 	widget/src/windows/nsWindow.cpp:1267
77 	user32.dll 	InternalCallWinProc 	
78 	user32.dll 	UserCallWinProcCheckWow 	
79 	user32.dll 	DispatchMessageWorker 	
80 	user32.dll 	DispatchMessageW 	
81 	xul.dll 	nsAppShell::ProcessNextNativeEvent 	widget/src/windows/nsAppShell.cpp:165
82 	winmm.dll 	timeGetTime 	
83 	xul.dll 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:296
84 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:508
85 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
86 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:193
87 	nspr4.dll 	PR_GetEnv 	
88 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:110
89 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/src/crtexe.c:591
90 	kernel32.dll 	BaseProcessStart 	

mshtml.dll 	6.0.2900.5880 	833F7852A6E4449DADBD4FA773E9A7FC2 	mshtml.pdb
jscript.dll 	5.7.6002.22145 	A8CAD2E29519405EAFF843A425B2A5CB2 	jscript.pdb
ole32.dll 	5.1.2600.5512 	ED517599D2C14CF19200861833059C142 	ole32.pdb
npietab.dll 	1.3.0.1 		

Extension 	Extension Id 	Version 	Current?
IE Tab 	{77b819fa-95ad-4f2c-ac7c-486b356188a9} 	1.5.20090525 	current

Your crash is roughly caused by ietab (you're crashing in a library we would never load on our own).
Component: Bookmarks & History → Extension Compatibility
QA Contact: bookmarks → extension.compatibility
Summary: Drag Bookmark downwards on bookmarktoolbar causes Firefox crash [@ mshtml.dll@0x17681b ] → IETab Drag Bookmark downwards on bookmarktoolbar causes Firefox crash [@ mshtml.dll@0x17681b ]
(Reporter)

Comment 5

9 years ago
With your information and some further investigations, I now can reproduce the bug and force a crash:

- Open a tab within Firefox that shows a webpage
- The content must be rendered via IE (IEtab plugin)
- Now grab any bookmark from the bookmarktollbar and shake it around
--> crash after some "shakes"

Additional informations:
- It does not depend on the bookmark
- Crash does not occur when IEtab-page is in background (open additional FF-Tab, focus it and shake a bookmark)



PS. @timeless: Unfortunately IE is a company policy. I must use it for internal pages as several things wouldn't work.

Comment 6

9 years ago
*shrug*. you're crashing in Microsoft code loaded by a third party extension, you can complain to Microsoft, you can complain to ietab, or you can stop using the extension. There's very little we can do about it.

It is remotely possible that our drag and drop code is doing something wrong, but the fastest way to determine this would be for someone from Microsoft to review the crash and identify that.

actually, since we don't have any useful symbols for the ms libraries, you could probably get a better stack trace (which could probably help someone).

Please follow the instructions here:
http://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
and reproduce your crash.
Summary: IETab Drag Bookmark downwards on bookmarktoolbar causes Firefox crash [@ mshtml.dll@0x17681b ] → IETab Drag Bookmark downwards on bookmarktoolbar causes Firefox crash [@ mshtml.dll@0x17681b ] CInterfaceFromWindowProp::PrivDragDrop / nsDragService::StartInvokingDragSession
(Reporter)

Comment 7

9 years ago
set priority to "normal" as it semms not to be a firefox problem and (hopefully) IEtab is not used that often.
Severity: critical → normal
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Assignee)

Updated

7 years ago
Crash Signature: [@ mshtml.dll@0x17681b ]
You need to log in before you can comment on or make changes to this bug.