Javascript image array error

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Thomas.Wright, Assigned: jst)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m17) Gecko/20000807
BuildID:    2000080712

There is a problem with the image array in Javascript. This Script is a dynamic
menu which uses document.image.length while generating the menu to find out
which image should have the mouseover, then it prints a regular mouseover into
the document. I've tested it on RH Linux 6.2 and MS Windows 98 with this Mozilla
build 2000080712 (other OSs not tested). IE 5 and Netscape 4.72 display it
correctly.

Reproducible: Always
Steps to Reproduce:
1. click on the "produkte" or any other link at top of page
2. use the javascript menu, the mouseovers are wrong


Actual Results:  the first picture on page is moused-over instead of the picture
the mouse is on. If one opens a tree branch, the first image in tree branch is
moused-over.

Expected Results:  the correct mouseover (works in other browsers)

Comment 1

18 years ago
Browser, not engine. Reassigning to DOM Level 0 for further triage -
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

Updated

18 years ago
Summary: Javascript image array error

Updated

18 years ago
Summary: Javascript image array error

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Confimed with 102708 mozilla trun kbuild on NT.
(Assignee)

Comment 3

18 years ago
It seems like this one was fixed since it was reported, the tree thingy on the
left side appears to be working just fine now. Marking WORKSFORME, please reopen
if there's still a problem...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
Verified with 2001-020608.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.