Message body text lines extends outside of screen and no horizontal scroll bar shown

RESOLVED WORKSFORME

Status

Thunderbird
Message Reader UI
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: etiourine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

When subject of the mail is enough long and can't be word-wrapped then text lines in the message body area are also not wrap and extends outside of screen. In such cases horizontal scroll bar for message body text area is not shown as well.

Reproducible: Always

Steps to Reproduce:
1.write a mail with long subject which can't be word-wrapped, for example, =A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4==A1=A2=A3=A4=

and with message body text containing enough long text lines - longer than line of text on your screen. For example, Hello world, Hello world, Hello world, Hello world, Hello world, Hello world, Hello world, Hello world, Hello world, Hello world, and so on... - this is one line of text

2. send this mail

3. receive this email. see message body area.
Actual Results:  
Message body text lines extends outside of screen and no horizontal scroll bar shown. It's not possible to read ALL text of the message.

Expected Results:  
Wrap text lines of message body, or at least [but this is actually not friendly] show horizontal scroll bar.
Reported against 3.0 where we had problems with wrapping subject that are now fixed.

Testcase of comment 0 wfm, subject is wrapped, long line in body gets scroll bar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Although... why isn't that long body line wrapped?
(In reply to Thomas D. from comment #2)
> Although... why isn't that long body line wrapped?

That was because I copied from bugzilla comment above, which had <pre>, so that was preserved after pasting and it came out as "preformat".
You need to log in before you can comment on or make changes to this bug.