If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Build CentOS 5.0 PXE image

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
critical
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: mrz, Assigned: justdave)

Tracking

Details

(Reporter)

Description

8 years ago
We have the first iX Systems 1u half depth server at 650 Castro and need to get CentOS 5.0 installed.

Would like to get this up today.  Let me know if that can't happen.

Need:
1. CentOS 5.0 PXE image setup on mvadm01
2. Updated e1000 driver installed (mvadmn01:~root/e100e-1.1.2)
3. Kickstart file that mimics a normal build CentOS VM
(Reporter)

Comment 1

8 years ago
fyi, ipmi is up @ 10.250.2.58 with default login.
Assignee: server-ops → justdave
Severity: minor → critical
(Reporter)

Updated

8 years ago
Depends on: 535300
I'm not sure what's involved in building a PXE image, but we have a kickstart file that gets us to the base system we use. It's here, https://bug419924.bugzilla.mozilla.org/attachment.cgi?id=306233

We'll have to a bunch of post-install setup manually though. I'm happy to do this today or tomorrow, if that's ok with John.
You actually need 5.0 on this and not 5.4, right?
(Reporter)

Comment 4

8 years ago
Sadly yes :|
ok, 5.2 is what we have on the server already, since I have to grab a new one, is it 32 bit or 64 bit?
ok, confirmed on IRC, 32-bit it is.  ISOs are downloading now.
The PXE client on the machine claims there's no link on the main ethernet port.
ok, mrz hooked up the ethernet earlier, got this working now.

type 'centos50-supermicro' at the PXE prompt.

It uses the kickstart supplied in comment 2, with the option added to force a reboot when it's done.  The %post script also fetches and installs the network driver (which will need to be rebuilt if you ever upgrade the kernel), and sets up the yum repositories to point only at the network-mounted CentOS 5.0 image (so you can use yum to install new packages that weren't previously installed, and they'll come off the 5.0 CD instead of up-to-date repositories)
(Reporter)

Comment 9

8 years ago
Nice!

Dave, forward login info to releng and close this out!
IP address is 10.250.3.156.  The root password is whatever that kickstart file sets it to.  The IP is pool-assigned via DHCP, if this machine is actually sticking around we should probably assign a static one for it.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.