If there are Weave Server timeouts due to work etc, Weave should tell a user with a message

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: for.bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4
Build Identifier: Weave 1.0pre1

Now there are messages in the message panel for
-could not connect to server
-Weave outdated, update needed

like title said, when there is work to the server, a user should know this so he doesn't think it is a trouble on his machine.

This avoids messages as
http://groups.google.com/group/mozilla-labs-weave/browse_frm/thread/ed54264be15bd295#
that are read by no one, except if the problem is already there.

Reproducible: Always
Unless Zandr did something really weird, the server should be returning 503 Database Unavailable. 

Punting this over to Ed, to see if it's an issue the client can address, and whether the email cited there was actually correct in the belief that it was caused by the outage.
Assignee: telliott → edilee
(Reporter)

Comment 2

9 years ago
Created attachment 417957 [details]
Proposal of the message in the UI

Database Unavailable can be everything
Is it not so the server should return an other error code?

Updated

9 years ago
Assignee: edilee → nobody
Component: Server → Needs Triage
QA Contact: server → needstriage

Updated

8 years ago
Component: Needs Triage → General
QA Contact: needstriage → general
offers Server Status button taking you to https://services.mozilla.com/status/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.