Search at Inbox level of Smart Folders Extremely Slow

RESOLVED DUPLICATE of bug 537820

Status

RESOLVED DUPLICATE of bug 537820
9 years ago
9 years ago

People

(Reporter: acugnini, Assigned: Bienvenu)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0

Search at Inbox level that includes IMAP email server is extremely slow.  Client appears to query IMAP server instead of searching local subject list.

Reproducible: Always

Steps to Reproduce:
1. Click on Inbox
2. Enter search term in search window
3. Wait forever -- entire client hangs while searching.
What search are you using : 

 * search all message or the others ?
 * Can you log the imap  protocol so we can see that' it's not searching locally (see https://wiki.mozilla.org/MailNews:Logging)
Keywords: perf

Comment 2

9 years ago
I would think this is bug 533865
(Reporter)

Comment 3

9 years ago
I am using "Search" with "Subject or From filter".

imap logfile attached.

(In reply to comment #1)
> What search are you using : 
>  * search all message or the others ?
>  * Can you log the imap  protocol so we can see that' it's not searching
> locally (see https://wiki.mozilla.org/MailNews:Logging)
(Reporter)

Comment 4

9 years ago
Created attachment 419609 [details]
requested imap.log file
(In reply to comment #4)
> Created an attachment (id=419609) [details]
> requested imap.log file

Looks like the search is happening online (but I'm not sure).
(Assignee)

Comment 6

9 years ago
yes, this is a dup - I have a fix that I hope to get into 3.01, if it gets approved.
Assignee: nobody → bienvenu
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537820
You need to log in before you can comment on or make changes to this bug.