Thunderbird, Fennec and Other icons need transparent backgrounds on new bug page

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
--
trivial
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: mlissner@michaeljaylissner.com, Unassigned)

Tracking

Details

(Whiteboard: [bmo4.0-resolved])

Attachments

(5 attachments, 2 obsolete attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7pre) Gecko/20091212 Ubuntu/9.10 (karmic) Firefox/3.5.2
Build Identifier: 

This is entirely a nitpick, but on the new bug page, TB, Calendar and Camino need to have transparent backgrounds. They currently have white ones, which is usually OK, but when different themes are used on BMO, they look bad, bad, bad.

Reproducible: Always

Steps to Reproduce:
1. Change your theme to one that doesn't use a white background
2. Click on New at the top of your screen.
I'll be the first to admit that I'm not a graphic artist.  If someone can submit modified versions of these icons with the transparency done correctly, I'll be happy to replace them.
Status: UNCONFIRMED → NEW
Ever confirmed: true
https://bugzilla.mozilla.org/enter_bug.cgi?full=0 for reference.

Thunderbird, Calendar, Camino, and Other Products all appear to have this problem.
Use View > Page Style > Dusk to see them on a darker background.
FWIW, I found Thunderbird logos on spreadthunderbird.com with a proper alpha channel, but they look like crap when I scale them down to 64x64.
Found a 64x64 Sunbird icon with proper transparency at http://markcarson.com/MarkCarson/Asp/SunbirdIcons.asp
Created attachment 418311 [details]
64x64px Camino icon with alpha transparency

Everyone should please feel free to CC me to bugs when you need Camino graphics ;-)
(In reply to comment #2)
> https://bugzilla.mozilla.org/enter_bug.cgi?full=0 for reference.
> 
> Thunderbird, Calendar, Camino, and Other Products all appear to have this
> problem.

Also, I don't seem to see any logos on that page. :?
You need to change your Bugzilla prefs, set "Product chooser to use when entering bugs" to the "Pretty chooser".
Duplicate of this bug: 472275
Current status:

Firefox: transparent
Sunbird: transparent
SeaMonkey: transparent
Mozilla Dino: transparent
Camino: transparent (white now, but I integrated the one in this bug in my tree)

Mozilla Application Suite: square anyway
Labs: square anyway

Thunderbird: white
'Other': white
Fennec: white border, then transparent

If someone wants to upload fixed versions of those last three, we can take them.

Gerv
Summary: Thunderbird, Calendar and Camino need transparent backgrounds on new bug page → Thunderbird, Fennec and Other icons need transparent backgrounds on new bug page
Created attachment 507214 [details]
Thunderbird logo

Does this work for the Thunderbird logo.
rebron: We need 64x64. If you are happy with me downsizing it in The Gimp, I will, but if you have an official version, let's have that :-)

Gerv
Created attachment 507226 [details]
56x64

Gerv, I got to 56x64.  Do you need it to 64x64 exact?  I'm fine with you modifying in gimp if I can review it.
Created attachment 507398 [details]
64x64 full size

rebron: to be the same as the other icons, it needs to go all the way to the box borders. How about this - 64x64 and filling the space?

Gerv
Attachment #507214 - Attachment is obsolete: true
Attachment #507226 - Attachment is obsolete: true
Attachment #507398 - Flags: review?(rebron)
Comment on attachment 507398 [details]
64x64 full size

Looks good.
Attachment #507398 - Flags: review?(rebron) → review+
OK, I checked that one in. Still needing Fennec and Other.

Gerv
Created attachment 520130 [details]
fixed fennec logo
Created attachment 520131 [details]
fixed "other" logo
Created attachment 520134 [details]
fixed dino logo

the dino logo is also broken; it's a 50x50 image being upscaled by the browser.  here's a fixed version.
The fennec logo seems small compared to the others; is that just because of the wings?

Otherwise, seems fine - ship it on bmo-4.0.

Gerv
(In reply to comment #20)
> The fennec logo seems small compared to the others; is that just because of the
> wings?

correct; it isn't as square as the other logos.
Whiteboard: [bmo4.0-resolved]
Duplicate of this bug: 651828
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.