Closed Bug 535410 Opened 10 years ago Closed 10 years ago

Red close buttons should have a pushed-in state

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: madhava, Assigned: vingtetun)

Details

Attachments

(2 files)

Attached image the pressed-in state
Red close-buttons should have a pressed-in state for feedback reasons.  These show up in the tab area, on notification bars, and on the Form Assistant.

Here it is in a mockup: http://mozilla.seanmartell.com/fennec/closePressed.png

PNG for the pressed-in state is attached.
Attached patch wip-1Splinter Review
This patch add the pressed state for the close button but for now I'm missing the pushed 16x16 close button image.

Madhava can you give me one? 
(I can't make it from the 40px one because the normal 16px one is not the same as the normal 40px one)
btw, I think it is really helpful to know _when_ you are going to close the tab - which mean I'll be happy to see this in 1.0
Assignee: nobody → 21
Comment on attachment 423818 [details] [diff] [review]
wip-1

works ok and we are removing the 16px (browser-low.css) stuff anyway.
Attachment #423818 - Flags: review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/0bb0f1360561
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
sigh...verified FIXED on builds:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2.2pre) Gecko/20100219 Namoroka/3.6.2pre Fennec/1.1a1

and

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.2pre) Gecko/20100219 Namoroka/3.6.2pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a2pre) Gecko/20100219 Namoroka/3.7a2pre Fennec/1.1a2pre

...but follow up bug 547249 has been filed due to a regression on maemo devices.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.