SeaMonkey 2.0 Fails to open a SHTML file from the hard drive

RESOLVED DUPLICATE of bug 535384

Status

--
major
RESOLVED DUPLICATE of bug 535384
9 years ago
9 years ago

People

(Reporter: rodndtube, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.23) SeaMonkey/2.0

I have a problem when attempting to open an SHTML file from my hard drive in SeaMonkey - not a problem accessing SHTML files on the Internet. No problem accessing a file on my HD with an HTML file. Everything was operating normally through Nov 8, 2009, until the next time I tried on Nov 23, 2009.

When attempting to open an SHTML file from within SeaMonkey the message is

"The file "filename.shtml" is of type application/x -itunes-itlp (Firefox Document), and SeaMonkey does not know how to handle this file type."

See dialog box: http://rodndtube.com/rodtemp/x-itunes-itlp_error.jpg

When attempting to open an SHTML file by double-clicking on it, SeaMonkey opens empty tabs one after the another.

Desktop program version with problem:
SeaMonkey 2.x (uninstalled after this problem)
FireFox 3.5.5
iTune 9.0.2.25

My desktop does not have this problem:
SeaMonkey 1.1.18
FireFox 3.5.5
iTune 9.0.2.25

My laptop does not have this problem:
SeaMonkey 1.1.1.14
FireFox 3.5.5
iTune 9.0.0.70


Reproducible: Always

Steps to Reproduce:
1.See above description.
2.
3.


Expected Results:  
Opened an SHTML file normally.
> "The file "filename.shtml" is of type application/x -itunes-itlp (Firefox Document), ...

Fllowing is setup of Apache for .shtml file
> http://httpd.apache.org/docs/1.3/howto/ssi.html
>  AddType text/html .shtml
Dou you correctly associate proper mime-type to file extension of .shtml?
Check next key of Windows registry.
> HKEY_CLASSES_ROOT\.shtml

Comment 2

9 years ago
Reporter wants to open the file by double clicking. I doubt that Apache is used.

Reporter, please select in that dialog: Open it with - Browse - C:\program files\seamonkey\seamonkey.exe and try again.
(In reply to comment #2)
> Reporter wants to open the file by double clicking. I doubt that Apache is used.

Presentation of Apache's setting is to let him know proper mime-type for .shtml.
As Seamonkey 2 is invoked by double-click of local .shtml file on MS Win, Sm 2 is successfully associated to .shtml on his MS Win.

Comment 4

9 years ago
> Reporter, please select in that dialog: ...

I meant Seamonkeys own Open Unknown Files dialog shown here http://rodndtube.com/rodtemp/x-itunes-itlp_error.jpg.
(Reporter)

Comment 5

9 years ago
(In reply to comment #1)
> > "The file "filename.shtml" is of type application/x -itunes-itlp (Firefox Document), ...
> 
> Fllowing is setup of Apache for .shtml file
> > http://httpd.apache.org/docs/1.3/howto/ssi.html
> >  AddType text/html .shtml
> Dou you correctly associate proper mime-type to file extension of .shtml?
> Check next key of Windows registry.
> > HKEY_CLASSES_ROOT\.shtml

FireFox and SeaMonkey 1.1.18 are currently installed. The HKEY_CLASSES_ROOT\.shtml default values is "FirefoxHTML" but SHTML is associated with SeaMonkey and opens SeaMonkey on double clicking a SHTML file with no problem.
(Reporter)

Comment 6

9 years ago
(In reply to comment #2)
> Reporter wants to open the file by double clicking. I doubt that Apache is
> used.
> 
> Reporter, please select in that dialog: Open it with - Browse - C:\program
> files\seamonkey\seamonkey.exe and try again.

That did not work - trying to open a SHTML file with SeaMonkey 2.0 resulted in continous black tabs being opened.
(In reply to comment #5)
> > > HKEY_CLASSES_ROOT\.shtml
> 
> FireFox and SeaMonkey 1.1.18 are currently installed. The
> HKEY_CLASSES_ROOT\.shtml default values is "FirefoxHTML" but SHTML is
> associated with SeaMonkey and opens SeaMonkey on double clicking a SHTML file
> with no problem.

I'm asking about mime-type associated to .shtml on your MS Win.
What value is set in "Content-Type" of the key of Windows registry?
(Reporter)

Comment 8

9 years ago
FireFox and SeaMonkey 1.1.18 are currently installed - registry states:
HKEY_CLASSES_ROOT\.shtml
default value is "FirefoxHTML"
Content Type is text/html
PerceivedType is text
OpenWithList Default value is "(value not set)
(In reply to comment #8)
> HKEY_CLASSES_ROOT\.shtml
> Content Type is text/html

Properly registered to Windows registory.

> FireFox and SeaMonkey 1.1.18 are currently installed.
> The HKEY_CLASSES_ROOT\.shtml default values is "FirefoxHTML" but SHTML is associated 
> with SeaMonkey and opens SeaMonkey on double clicking a SHTML file with no problem.

You probably downloaded SHTML file(.shtml) of mime-type="application/x-itunes-itlp" by Sm2 or received mail with such SHTML file attachment by Sm2, and you replied "do this always" at dialog for open action. Check mimeTypes.rdf in Sm2's profile directory by text editor. Do you see string of "application/x-itunes-itlp" and/or ".shtml" in the file?

> FireFox and SeaMonkey 1.1.18 are currently installed

If entry is found and if you can accept loss of contents in mimeTypes.rdf,
delete mimeTypes.rdf and restart Sm2.

If you can't accept loss of current mimeTypes.rdf data, do one of next please.
(A) Manual recovery using Sm1's "Helper Applications"
(1) create new profile with Sm1, (2) copy Sm2's mimeTypes.rdf to Sm1's profile, (3) remove garbages via Preference/Browser/Helper Applications of Sm1, (5) copy back Sm1's mimeTypes.rdf to Sm2's profile.
(B) Copy Sm1's mimeTypes.rdf to Sm2's profile.
Because of Bug 462629, Sm1 is retuired to clean up garbages in mimeTypes.rdf.
(Reporter)

Comment 10

9 years ago
12/19/2009. Uninstalled SeaMonkey 1.1.18, rebooted, and installed SeaMonkey 2.01.

1. Try to open an SHTML file from my hard drive; result is this message "dummy2.shtml could not be opened, because the assodated helper application does not exist. Change the association in your preferences." See:
http://rodndtube.com/rodtemp/%5Bimg%5Dsnapshot2009-1219-1.jpg

2. In Preferences|Browswer|Helper Applications the only relevant entry I found was "Firefox Document" - it also made the reference to "application/x -itunes-itlp". I changed this file association to Firefox. I then used File Open to open an SHTML file and it opened in Firefox.

3. I changed the association to SeaMonkey, tried to open the same SHTML file and SeaMonkey proceeded to open several blank tabs. See:
http://rodndtube.com/rodtemp/%5Bimg%5Dsnapshot2009-1219-2.jpg

4. At this point the Windows Registry (WinXP) entry in HKEY_CLASSES_ROOT\.shtml is:
- default values is "FirefoxHTML"
- OpenWithList value name is Default "value not set"
5. At this point the Windows Registry entry in HKEY_CLASSES_ROOT\.itlp is:
- default values is "iTunes.itlp"
- OpenWithList value name is Default "value not set"
  - Subfolder for OpenWithList is iTunes.exe with a Default "value not set"
- OpenWithProgids are two value name entries: (1) Default "value not set" and (2) iTunes.itlp (nothing else)

6. Found this entry: C:\Documents and Settings\Rod\Application Data\Mozilla\SeaMonkey\Profiles\qkyw7aly.default\mimeTypes.rdf

<RDF:Description RDF:about="urn:mimetype:application/x-itunes-itlp"
                   NC:value="application/x-itunes-itlp"
                   NC:editable="true"
                   NC:fileExtensions="shtml"
                   NC:description="Firefox Document">
    <NC:handlerProp RDF:resource="urn:mimetype:handler:application/x-itunes-itlp"/>
  </RDF:Description>

Deleted it, no impact. At this point my recollection is a littel foggy - believed I deleted the RDF file to no effect.

7. Let SM2.01 reside in its directory, \SeaMonkey2\ and installed SM1.1.18 in its usual directory \SeaMonkey\. Maybe deleted the RDF files here. Can now open a SHTML file in SM2, but could not change the file association to access SeaMonkey2 when double clicking on an SHTML file since Windows would only recognize one seamonkey.exe file.

8. Changed the name of the SM2 seamonkey.exe file to seamonkey2.exe. Everything seems to work - was able to change the SHTML file name association to seamonkey2.exe. All is in order. Will there be any issues with using seamonkey2.exe, e.g., during periodic program updates or for other reasons? I am hesitant to uninstall SM1.1.18 at this point.
Duping to bug 535384 (application/force-download + .pdf version of this bug).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 535384
You need to log in before you can comment on or make changes to this bug.