Memory seems to leak very quickly and cause firefox to consume all my processor power

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: jason buksh, Unassigned)

Tracking

({perf})

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-02-01])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 GTB6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 GTB6

I have a 4gb, Intel Duo laptop.  
I like using firefox - or did
For some reason - after a short period of time my computer starts to "freeze" .... when inspecting the task manager I see that firefox is consuming most of my available memory. 
Even now - with just this tab open I can see that the memory allocated is 188,999k ...... too much . 
The issue has become so bad and regular that I am now switching most of my usage to Chrome. 
When the my computer starts becomes unusable - I **** down Firefox.  It take a little time to "garbage" collect, but when it does my computer becomes usable again. 


Reproducible: Always

Steps to Reproduce:
1. Leave firefox running
2. Watch memory consumption go up - and not down (even If I close all tabs)
3. Close firefox - open chrome


Expected Results:  
I would expect firefox to consume only the heap space it needs

Sony Viao - I have a 4gb, Intel Duo laptop. Running Vista

This needs to be fixed - if its happening to me, its happening to many - and causing them to switch

If you wish to monitor my PC you are welcome to run some debugging/monitoring process on it

Comment 1

8 years ago
the same have happened to me, it started to versions ago and its pretty annoying..

Comment 2

8 years ago
does this happen started in safe mode https://support.mozilla.com/en-US/kb/Safe+Mode ?
Keywords: perf
Whiteboard: [closeme 2010-02-01]
Version: unspecified → 3.5 Branch

Comment 3

8 years ago
=> incomplete due to no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

8 years ago
Started it in safe mode - and couldn't reproduce the  memory leak issue.  What would you like me to do now?
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 5

8 years ago
I must say - that because of this issue I have mostly switched to Chrome.  I only have a few extensions/plugins (and can only assume one of these is causing the issue).

Comment 6

8 years ago
Thanks for testing in safe mode. If it doesn't leak in safe mode, then the problem is one of the add-ons or themes you installed. You will want to test them one at a time to find which one is causing the problem.

Is the amount of memory you cite in comment 0 correct, 188MB?  That's not really much memory.

Comment 7

8 years ago
no in normal mode

Comment 8

8 years ago
the problem seems to be with the add-ons, tried disabling some of them and enabling one and one add-on. The problem seems to be with old java add-ons, if you still got the old versions of the java add-ons installed after you have updated java, then removing the old versions fixed this problem for me. Firefox was using up to about 650Mb of RAM, now its using about 60-116Mb and between 0-6% CPU.

Comment 9

8 years ago
Update: left Firefox 3.6 running for some hours now without using my PC to test if the problem was totally solved and it was using 289Mb RAM after some hours. I got Java console 6.0.17, Microsoft .net framework assistant 1.1, skype extension for Firefox 3.3.0.3971, win amp toolbar 5.6.11.2, downloadhelper 4.7 add-ons installed. Pluss one that's auto disabled because its not compatible with Firefox 3.6. The win amp toolbar that I got seems to cause the same Firefox behavior as with the old java console add-ons. Disabling the win amp toolbar too finally sorted this problem :-D. Now Firefox 3.6 is only using about 40Mb RAM with to tabs open.
Per-ole, yes, uninstall all old java, then install java 6update19.
Reporter, are you still seeing this?

Comment 11

8 years ago
the problem seems to be fixed on firefox 3.6.3 :D, now its using about 78.6Mb RAM with only one tab open after about 20hrs with Java 6 update 17 installed. Have just installed Java 6 update 20 will leave it open for some hours and see if it still uses 78.6Mb of RAM.

Comment 12

8 years ago
Left firefox running with one tab open till now and it was using almost 600MB of RAM. Have disabled the Java add-on now and will leave it running till tomorrow and see if the problem is still there

Comment 13

8 years ago
the problem seems to be related to the Java add-on, with the Java add-on disabled it was only using about 63MB with one tab open till now. Try to do the same and see if it fix the problem for you too. Someone needs to confirm this bug so that it gets fixed, it have been there for too long now

Updated

8 years ago
Flags: blocking1.9.0.19?
per-ole,what version of java do you have?
Flags: blocking1.9.0.19?

Comment 15

8 years ago
Java 6 update 20 as stated in one of the above replies
Please report to java. We can't really fix their addon.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID

Comment 17

8 years ago
will do. We didnt knew what caused it before now

Comment 18

8 years ago
of course not. its reported now btw
You need to log in before you can comment on or make changes to this bug.