Closed Bug 535441 Opened 15 years ago Closed 1 month ago

[OOPP] mozilla-runtime is treated as a completely separate app by Firewall software

Categories

(Core :: IPC, defect)

x86_64
Windows 7
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: lh.bennett, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091216 Minefield/3.7a1pre Firefox/3.5.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091216 Minefield/3.7a1pre ID:20091216100208

Filed as requested. I apologize if its a dupe.

Windows 7(x64)
Comodo Firewall 3.13 (Windows Firewall is Off)

The mozilla-runtime is treated as a completely separate program by Firewall software.

On load of a plugin, the process is caught by the Firewall software attempting to connect to the web. As in, if firefox.exe is already allowed to connect, those same properties would not work for mozilla-runtime.exe.

I understand that Chrome gets around this issue by having the main app being called to create the new processes. That way, all processes use the same firewall rules.

Reproducible: Always
Version: unspecified → Trunk
Component: IPC → Plug-ins
Hardware: x86 → x86_64
Component: Plug-ins → IPC
Blocks: OOPP
Severity: normal → S3

e10s has been shipping for a long time so hopefully issues with process names or whatever have been resolved.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.