Last Comment Bug 535466 - Turn "Adding child where we already have a child?" warning back into an assertion
: Turn "Adding child where we already have a child?" warning back into an asser...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All All
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 307241 314457 344216 396836 632835
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-16 18:20 PST by Jesse Ruderman
Modified: 2012-04-19 23:04 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jesse Ruderman 2009-12-16 18:20:54 PST
I'm turning this into a warning for now, since many crashtests hit it.  This bug tracks turning it back into an assertion.

###!!! ASSERTION: Adding child where we already have a child?  This will likely misbehave: 'Error', file /Users/jruderman/central/docshell/shistory/src/nsSHEntry.cpp, line 598
Comment 1 Daniel Holbert [:dholbert] 2012-04-19 16:11:34 PDT
Bug 632835 converted it back into an assertion. (replacing NS_WARN_IF_FALSE with a NS_ERROR):
  http://hg.mozilla.org/mozilla-central/rev/ee2e22296d3c

Resolving as FIXED by that bug.

Note You need to log in before you can comment on or make changes to this bug.