Closed Bug 535490 Opened 10 years ago Closed 7 years ago

Intermittent timeout: browser_privacypane_6.js

Categories

(Firefox :: Preferences, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Firefox 3.7a5

People

(Reporter: masayuki, Assigned: ehsan)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261011286.1261020613.8052.gz#err1

> TEST-PASS | chrome://mochikit/content/browser/browser/components/preferences/tests/browser_privacypane_6.js | private browsing menu item should be enabled
> TEST-PASS | chrome://mochikit/content/browser/browser/components/preferences/tests/browser_privacypane_6.js | private browsing command should be enabled
> TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/preferences/tests/browser_privacypane_6.js | Timed out
> Waiting for window activation...
> TEST-INFO | chrome://mochikit/content/browser/browser/components/preferences/tests/browser_privacypane_6.js | Console message:
> TEST-INFO | chrome://mochikit/content/browser/browser/components/preferences/tests/browser_privacypane_6.js | Console message:
> TEST-INFO | chrome://mochikit/content/browser/browser/components/preferences/tests/browser_privacypane_6.js | Console message:
> Running chrome://mochikit/content/browser/browser/components/preferences/tests/browser_privacypane_7.js...

Linux mozilla-central debug test everythingelse on 2009/12/16 16:54:46  
s: moz2-linux-slave13
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261073760.1261082328.26203.gz
Linux mozilla-central debug test everythingelse on 2009/12/17 10:16:00
s: moz2-linux-slave01
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261392516.1261402780.21344.gz
Linux mozilla-central debug test everythingelse on 2009/12/21 02:48:36
s: moz2-linux-slave22
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262883874.1262893054.15096.gz
Linux mozilla-central debug test everythingelse on 2010/01/07 09:04:34
s: moz2-linux-slave10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265928360.1265933013.26893.gz
Linux mozilla-central debug test mochitest-other on 2010/02/11 14:46:00
s: moz2-linux-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267580902.1267583915.10883.gz
Linux mozilla-central debug test mochitest-other on 2010/03/02 17:48:22
s: moz2-linux-slave06
Blocks: 438871
Attached patch Patch (v1)Splinter Review
Since all of these failures have happened on debug builds, this is almost 100% a real timeout caused by the test taking too long to run.  Let's split that test.
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #449209 - Flags: review?(gavin.sharp)
Attachment #449209 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/802221c97140
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a5
Reopening based on comment 11.  This test should probably be split into more tests...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 10 years ago7 years ago
Resolution: --- → WORKSFORME
Reopening based on comment 11, comment 12, and comment 13 :)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [orange]
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.