Closed Bug 535685 Opened 11 years ago Closed 11 years ago

xpcwrappedjs doesn't deal with dipper parameters properly

Categories

(Core :: XPConnect, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mrbkap, Assigned: mrbkap)

References

Details

Attachments

(1 file)

In particular, it doesn't create an out object for JavaScript to stick stuff in.
Attached patch Proposed fixSplinter Review
Assignee: nobody → mrbkap
Status: NEW → ASSIGNED
Attachment #418298 - Flags: review?(peterv)
Blocks: 513798
Yay, this fixes the problem for me.

In particular (to jog my memory in the future lest I forget):

IDL:

  void generateKeypair(in ACString aPassphrase, in ACString aSalt,
                       in ACString aIV, out ACString aEncodedPublicKey,
                       out ACString aWrappedPrivateKey);

JS impl being called from JS was failing in the return. bkap's workaround in the impl was:
        if (typeof outparam != "object");
            outparam = {};

Woo!
Comment on attachment 418298 [details] [diff] [review]
Proposed fix

Needs test.
Attachment #418298 - Flags: review?(peterv) → review+
http://hg.mozilla.org/mozilla-central/rev/420131e7219d

I don't have time to write the test for this.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Duplicate of this bug: 322597
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.