font style changes to variable width repeatedly

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 250539
8 years ago
8 years ago

People

(Reporter: WOLF_THUNDER, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

When composing, or replying to, a message if I move the cursor with the mouse to the end of the message and start typing again, the font settings are lost and it reverts to variable width.  This is very annoying when trying to compose a message with some uniformity.  Same problem in Thunderbird 2 that I was hoping a new version would correct.  Similar to Bug 514265, although it does not happen to me mid typying, only if I use the mouse to paste or move in the compose / reply area.

Reproducible: Always

Steps to Reproduce:
1.Hit reply
2.start typing
3.move mouse to end of last sentence and start typing, now variable width
Actual Results:  
font changes to variable width, making the email look like ****.

Expected Results:  
font setting to maintain the default or assigned settings.

maintain the default font setting, or the font setting selected for the ENTIRE compose / reply space.  (If I hit several carriage returns to increase the reply space, then highlight the entire reply space and change the font settings, then move the mouse to somewhere in that area, the font settings are not preserved and it goes back to variable width.  VERY annoying)
(Reporter)

Comment 1

8 years ago
This seems worse in 3 tan 2.  If I notice a mistake and go back to fix it and then try to resume, the damn font changes to variable width.  A huge time waster to repeatedly have to reset the font over and over in just 1 message.

Comment 2

8 years ago
Yes, I agree that this may be happening more often in TB3 than in Tb2
But I have not been able to specifically identify a reliable way to reproduce.

If you could supply a testcase of an email in the form of an EML, that could help to pin this down.
(Reporter)

Comment 3

8 years ago
OK, I just tested a compose, and a reply and a foward.

It did NOT do it on the compose, I guess I reply and forward so often I thought it was doing it on compose too....

However, on the reply and on the forward, if click the down arrow 1 time on my keyboard when the cursor is in the body (on reply it auto selects, on forward I have to select it after moving off the address field), it switches to variable width, every time.  Find a message, hit reply, and then look at your font and hot the down area.  If you have pre selected a font in your settings other than variable width, it switches.

If you cannot reporduce that (Sorry about saying compose did it too), then I will be happy to send you a sample.  Let me know.

Thanks!
(Reporter)

Comment 4

8 years ago
hot the down area == hit the down arrow

Comment 5

8 years ago
With just some quick testing, I'm not seeing this.
For complex html compositions with bulleted list and tables etc, there are known
issues.
Probably the easiest way, is for you to send me an email which, when replied to shows the problem. That way I see the actual html.

Comment 6

8 years ago
WOLF_THUNDER,
Thanks for sending that test email.

I sympathize with your frustration with problems you see in a simple html reply
from an outlook client.(and others)
Better html composition an interoperability with clients like outlook is essential to the future of thunderbird. Keep the bug reports coming.
Xref bug 31052
Duping to bug 250539
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.