Content-type : application/xslt+xml not viewed in browser as XML

NEW
Unassigned

Status

()

enhancement
10 years ago
3 years ago

People

(Reporter: locki, Unassigned)

Tracking

(Depends on 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6

As per title, files of the the correct XSLT 2 MIME-type "application/xslt+xml" (http://www.w3.org/TR/xslt20/#media-type-registration) can't be viewed in the browser like those of "text/xsl" can.

Reproducible: Always

Comment 1

10 years ago
Can you provide an example url?
Reporter

Comment 2

10 years ago
Sure, here's a directory of examples : http://l0x.in/xml/xsl/

Comment 3

10 years ago
This looks to be a duplicate of Bug 155730
We will call it that for now...
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: */*+xml
Given that we're pretty likely to wontfix bug 155730, it might make more sense to mark this dependent instead...
Status: RESOLVED → UNCONFIRMED
Depends on: */*+xml
Resolution: DUPLICATE → ---
And in particular it's quite doable to make this one type be treated as XML, and it might well be desirable to do so.
At first glance I'd prefer to fix bug 155730. But if that really isn't happening then I guess hardcoding this mimetype (and a bunch of other ones) is ok...
I guess no point in keeping this an UNCO in Firefox:general, then.
Status: UNCONFIRMED → NEW
Component: General → File Handling
Ever confirmed: true
OS: Windows 7 → All
Product: Firefox → Core
QA Contact: general → file-handling
Hardware: x86 → All
Version: unspecified → Trunk

Updated

3 years ago
Product: Core → Firefox
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.