Closed Bug 535891 Opened 10 years ago Closed 10 years ago

[SeaMonkey 2.1] mochitest-a11y: "[SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.loadURI is not a function at chrome://mochikit/content/a11y/accessible/test_events_scroll.xul:57", and test_name_nsRootAcc.xul too

Categories

(Core :: Disability Access APIs, defect, major)

x86
All
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla1.9.3a1

People

(Reporter: sgautherie, Assigned: surkov)

References

(Depends on 1 open bug, Blocks 2 open bugs, )

Details

Attachments

(1 file)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a1pre) Gecko/20091218 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)

{
1151 INFO TEST-PASS | chrome://mochikit/content/a11y/accessible/test_events_scroll.xul | maybe run tests <load:true, focus:true> -- loaded: complete active window: ([object ChromeWindow]) chrome://navigator/content/navigator.xul focused window: ([object XPCNativeWrapper [object Window]]) chrome://mochikit/content/a11y/accessible/test_events_scroll.xul desired window: ([object XPCNativeWrapper [object Window]]) chrome://mochikit/content/a11y/accessible/test_events_scroll.xul docshell visible: true
1152 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_events_scroll.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.loadURI is not a function at chrome://mochikit/content/a11y/accessible/test_events_scroll.xul:57
}

after which every test fails with (multiple)
{
1159 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_events_tree.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - nsIAccessibleEvent is not defined at chrome://mochikit/content/a11y/accessible/events.js:766
}

and a summary example:
{
2552 INFO Passed: 8869
2553 INFO Failed: 184172
2554 INFO Todo:   5
}
Summary: mochitest-a11y: "[SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.loadURI is not a function at chrome://mochikit/content/a11y/accessible/test_events_scroll.xul:57" → [SeaMonkey 2.1] mochitest-a11y: "[SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.loadURI is not a function at chrome://mochikit/content/a11y/accessible/test_events_scroll.xul:57"
Same error with
{
1502 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/test_name_nsRootAcc.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.loadURI is not a function at chrome://mochikit/content/a11y/accessible/name_nsRootAcc_wnd.xul:82
}
but it's not causing the ill side-effect.
Summary: [SeaMonkey 2.1] mochitest-a11y: "[SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.loadURI is not a function at chrome://mochikit/content/a11y/accessible/test_events_scroll.xul:57" → [SeaMonkey 2.1] mochitest-a11y: "[SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.loadURI is not a function at chrome://mochikit/content/a11y/accessible/test_events_scroll.xul:57", and test_name_nsRootAcc.xul too
<?xml-stylesheet href="chrome://browser/content/browser.css" type="text/css"?>


In SeaMonkey, our tabbrowser binding is defined in:

<?xml-stylesheet href="chrome://navigator/content/navigator.css" type="text/css"?>
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Ports/1264292467.1264293435.24275.gz
Linux comm-central-trunk debug test mochitest-other on 2010/01/23 16:21:07
{
1520 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/events/test_scroll.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - tabBrowser.loadURI is not a function at chrome://mochikit/content/a11y/accessible/events/test_scroll.xul:57

1527 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/a11y/accessible/events/test_tree.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - nsIAccessibleEvent is not defined at chrome://mochikit/content/a11y/accessible/events.js:782

...

mochitest-a11y
31463/554411/2
}
Severity: normal → major
OS: Windows 2000 → All
Neil, is Seamonkey's tabbrowser different from mozilla-central one? Where are its sources?
Why do you need a tabbrowser, rather than an ordinary browser? But the problem isn't due to a difference in tabbrowser, but because you're trying to create the tabbrowser by loading Firefox's stylesheet, which we don't have.
Can you rewrite the test as a browser-chrome test to work in both browsers?
(In reply to comment #5)
> Why do you need a tabbrowser, rather than an ordinary browser? But the problem
> isn't due to a difference in tabbrowser, but because you're trying to create
> the tabbrowser by loading Firefox's stylesheet, which we don't have.

Because this is the test for the bug which happened when user switches between tabs. What stylesheet should I include additionally to make it work?
> What stylesheet should I include additionally to make it work?

chrome://navigator/content/navigator.css
(Mid-air collision detected!: anyway:)

Iiuc,

Test code is
{
4 <?xml-stylesheet href="chrome://browser/content/browser.css" type="text/css"?>
}
(for Firefox)

And bindings happen in
http://mxr.mozilla.org/comm-central/search?string=tabbrowser+%7B&case=on&find=%2Fbrowser%2F.*%5C.css

So you would need to load
<?xml-stylesheet href="chrome://navigator/content/navigator.css" type="text/css"?>
for SeaMonkey.

NB: Now, I'm not saying what the best way to code test support in m-c for /browser and /suite is...
Attached patch patchSplinter Review
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #423959 - Flags: review?(marco.zehe)
Blocks: a11ytestdev
Don't missing xml-stylesheets cause subsequent stylesheets to fail to load, or has this been fixed on trunk?
(In reply to comment #11)
> Don't missing xml-stylesheets cause subsequent stylesheets to fail to load, or
> has this been fixed on trunk?

I think it's fixed because I see warning in console Firefox's stylesheets wasn't loaded, but event/test_scroll.xul passes which means Seamoenky's stylesheets was loaded successfully.

I think we could use #ifdef but it's not very comfortable for tests development and debugging.
Attachment #423959 - Flags: review?(marco.zehe) → review+
landed on 1.9.3 - http://hg.mozilla.org/mozilla-central/rev/f1cf6e561351
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
(In reply to comment #13)
> landed on 1.9.3 - http://hg.mozilla.org/mozilla-central/rev/f1cf6e561351

I'm not sure why but this was an empty landing. Relanded - http://hg.mozilla.org/mozilla-central/rev/6e3003aeea75
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.3a1
Last run before check-in:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1265019158.1265021170.30299.gz
Linux comm-central-trunk debug test mochitest-other on 2010/02/01 02:12:38
Failed.

First run after check-in:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1265177678.1265179466.17592.gz
Linux comm-central-trunk debug test mochitest-other on 2010/02/02 22:14:38
Passed.
(Well, wrt this bug at least... Failure count dropped by 410k ;->)

V.Fixed
Status: RESOLVED → VERIFIED
Depends on: 558589
You need to log in before you can comment on or make changes to this bug.