[MF][FIX html.css]select drop down box border color problem

REOPENED
Unassigned

Status

()

Core
Layout: Form Controls
--
minor
REOPENED
18 years ago
13 years ago

People

(Reporter: James Lariviere, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in hand)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
DESCRIPTION:

select drop down box does not inherit the border color from the select element.


STEPS TO REPRODUCE:

view test case.

ACTUAL RESULTS:

Select drop down border renders with the default mozilla rendering border colors.

EXPECTED RESULTS:

Select drop down border should at the very least render with the html page
defined css select border color but ideally should render with the :focus
defined color.


DOES NOT WORK CORRECTLY ON:

Win98 build 2000091820 (9-18-00)
(Reporter)

Comment 1

18 years ago
Created attachment 15225 [details]
testcase - select drop down border color problem

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
This is nearly identical to bug 39992.

Comment 3

18 years ago
even putting border-color:inherit; in :-moz-dropdown-list rule doesn't help

Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 4

18 years ago
hey rod,

I changed:

:-moz-dropdown-list {
  background-color: inherit;
  border: 1px outset ThreeDFace;
  border-top-style: none;
  z-index: 2147483647;
  -moz-user-select: none;

to:

:-moz-dropdown-list {
  background-color: inherit;
  color: inherit;
  border-style: inherit;
  border-color: inherit;
  border-width: inherit;
  z-index: 2147483647;
  -moz-user-select: none;
}

and it works fine for win98 build 2000092420 in this test case and looks better
in the default rendering than what is existing.

Comment 5

18 years ago
Cool, that works! Thanks.
Summary: select drop down box border color problem → [FIX html.css]select drop down box border color problem
Whiteboard: Fix in hand

Comment 6

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
(Reporter)

Comment 7

18 years ago
hey rod,

what's the ETA for this to show up in the nightly's?

Comment 8

18 years ago
I could nomiate it for nsbeta3 or rtm, but it won't be considered bad enough to 
get fixed, even though it is a simple fix.
Change
  border-style: inherit;
  border-color: inherit;
  border-width: inherit;
...to
  border: inherit;
...if this is checked in.

Note that after release this will be moot once we change to XBL widgets.
I'm not sure we want this change; with inset borders (the result of the
change) the select drop downs look IMHO uglier than they are now. There is
no particular standards issue here at the moment, in CSS3 however there
will be a ::menu pseudo-class you can style, which will make all this moot 
as well...

I recommend WONTFIX. ;-)
(Reporter)

Comment 10

18 years ago
Ian,

The problem currently is that the select drop down does not match the styling of
the select element for normal or :focus (except color & background-color).

I think it is reasonable to expect that if you set a blue border-color for the
select, it's drop down box should have a blue border-color.

IMHO, I personally like the inset look of the drop down box so that it matches
the other form controls.  The 1px solid black drop down of IE and nav4 looks
really odd and out of place.

I suggest if you don't want to change this styling problem... that you should
not inherit the color or background-color from the select element because it
looks like the select element only "selectively" supports styling (kinda like MS
does).  Again IMHO.

Comment 11

17 years ago
It would be fine to inherit any of the colors, but not border-style or 
border-width. Altering those make the combo resize differently.
(Reporter)

Comment 12

17 years ago
adding mozilla0.9 to keywords because this would be a minor change:

  color: inherit;
  border-color: inherit;
Keywords: mozilla0.9

Comment 13

17 years ago
putting up on my radar
Summary: [FIX html.css]select drop down box border color problem → [MF][FIX html.css]select drop down box border color problem
Target Milestone: Future → ---
Setting milestone to future.
Target Milestone: --- → Future

Comment 15

17 years ago
QA Contact Update
QA Contact: bsharma → vladimire

Updated

16 years ago
Priority: P3 → --

Comment 16

14 years ago
Will this bug ever get fixed??? 
I believe this has been fixed already somewhere in the 1.7 cycle.
The testcase doesn't work in Mozilla1.7a (no changing border-colors for the
select element), but it does work in Mozilla1.7RC2.
Well, I could not see the problem anyhow (with the testcase), but I think this
is now certainly fixed by the fix for bug 244370.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Depends on: 244370
Resolution: --- → FIXED
Bug 244370 did not fix the dropdown *menu* (intentionally), which is what this
bug seems to be about (see comment 4).
Severity: normal → minor
Status: RESOLVED → REOPENED
No longer depends on: 244370
OS: Windows 98 → All
Hardware: PC → All
Resolution: FIXED → ---
Target Milestone: Future → ---

Updated

14 years ago
Assignee: rods → nobody
Status: REOPENED → NEW
Keywords: testcase
QA Contact: vladimire → core.layout.form-controls

Comment 20

13 years ago
WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Created attachment 174714 [details]
Testcase 2

The problem still occurs - the border color of the dropdown menu is black.
You need to log in before you can comment on or make changes to this bug.