[OOPP] Flash subprocess asserts `GDK_IS_WINDOW (window)' failed

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: sparky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20091218 Minefield/3.7a1pre Firefox/3.7
Build Identifier: 

Running Gentoo Linux, GTK+ 2.16.6, Flash 10.0.42.34, latest Firefox trunk

Happens in both 32bit and 64bit

Enable IPC plugins and visit a page with Flash content (i.e. youtube.com). The Flash subprocess appears to crash and Firefox hangs.

[PluginModuleParent] LoadModule
[PluginModuleChild] Init
[PluginModuleParent] NP_Initialize
[PluginModuleChild] AnswerNP_Initialize
[PluginModuleParent] NPP_New
[PluginModuleChild] AllocPPluginInstance
[PluginModuleChild] AnswerPPluginInstanceConstructor
(plugin args: type=application/x-shockwave-flash, src=http://s.ytimg.com/yt/swf/masthead_child-vfl89464.swf, style=, id=masthead_child, name=masthead_child, bgcolor=#FFFFFF, quality=high, allowfullscreen=false, allowscriptaccess=always, width=1, height=1, )
[PluginModuleChild] _getvalue
[PluginModuleChild] _getvalue
[PluginInstanceChild] NPN_GetValue(NPNVToolkit)
[PluginModuleChild] _useragent
[PluginModuleChild] _getvalue
[PluginInstanceChild] NPN_GetValue(NPNVWindowNPObject)
[PluginModuleChild] _createobject
[PluginModuleChild] _memalloc
[PluginModuleChild] _getstringidentifier
[PluginModuleChild] _getproperty
[PluginModuleChild] _createobject
[PluginModuleChild] _memalloc
[PluginModuleChild] _getstringidentifier
[PluginModuleChild] _invoke
[PluginModuleChild] _releasevariantvalue
[PluginModuleChild] _releasevariantvalue
[PluginModuleChild] _getvalue
[PluginInstanceChild] NPN_GetValue(NPNVWindowNPObject)
[PluginModuleChild] _createobject
[PluginModuleChild] _memalloc
[PluginModuleChild] _getstringidentifier
[PluginModuleChild] _getproperty
[PluginModuleChild] _createobject
[PluginModuleChild] _memalloc
[PluginModuleChild] _getstringidentifier
[PluginModuleChild] _getproperty
[PluginModuleChild] _createobject
[PluginModuleChild] _memalloc
[PluginModuleChild] _releasevariantvalue
[PluginModuleChild] _getstringidentifier
[PluginModuleChild] _invoke
[PluginModuleChild] _releasevariantvalue
[PluginModuleChild] _releasevariantvalue
[PluginModuleChild] AnswerPPluginInstanceConstructor: returning 0
[PluginModuleParent] NPP_New: got return value 0
[PluginInstanceParent] NPP_GetValue(NPPVpluginNeedsXEmbed)
[PluginModuleParent] NPP_SetWindow
[PluginInstanceChild] NPP_SetWindow(0x300070c, 5, 84, 1 x 1)
[PluginModuleChild] _getvalue

(<unknown>:14912): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

Not sure if this is a dupe of bug 530711 or not.

I'd provide a stacktrace, but I can't find a way to attach to the mozilla-runtime subprocess before it goes zombie.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
I should also mention that, while Firefox is hung, killing the mozilla-runtime process causes a segfault.

http://crash-stats.mozilla.com/report/index/9e92d7e5-dd5f-4ee7-b451-424d32091224
Summary: Flash subprocess asserts `GDK_IS_WINDOW (window)' failed → [OOPP] Flash subprocess asserts `GDK_IS_WINDOW (window)' failed
(Reporter)

Comment 2

9 years ago
Making a note that this is NOT fixed by Bug 539897

Also noting that, even though there have been a number of hang-related checkins, this still causes Firefox to hang.

However, killing the mozilla-runtime subprocess will no longer cause a crash. So that's an improvement.
(Reporter)

Comment 3

9 years ago
The Flash subprocess crash appears to be fixed within the changeset
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=caa4eb12ad20&tochange=fab327eb791b
My guess is that it was probably fixed by Bug 558390

Though I'm still seeing the GDK assertion:

(<unknown>:12091): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
  (child won, so we're deferring)
  (child won, so we're not deferring)
  (processing deferred in-call)

Not sure if this is a problem, as Flash now seems to be working (tested on YouTube).
(Reporter)

Comment 4

9 years ago
This has been fixed for a while.

Crash fixed by Bug 558390
Assertion fixed by Bug 561308
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.