Requesting account for uploading symbols for openSUSE Linux builds

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: wolfiR, Assigned: chizu)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 418497 [details]
ssh public key

I'm going to enable the crashreporter for xulrunner/firefox and thunderbird in openSUSE builds and crashes should get collected from mozilla systems.
Therefore need an upload account for the symbols on dm-symbolpush01.mozilla.org.

Comment 1

8 years ago
releng, ack?
Assignee: server-ops → nobody
Component: Server Operations → Release Engineering
QA Contact: mrz → release
Why does RelEng need to sign off on this? These are completely independent builds, just like bug 424061.

We can (and should) be uploading them to a separate directory with a different user account so there won't be any conflicts.

Comment 3

8 years ago
(In reply to comment #2)
> Why does RelEng need to sign off on this? These are completely independent
> builds, just like bug 424061.
> 
> We can (and should) be uploading them to a separate directory with a different
> user account so there won't be any conflicts.

Yeah, not really a releng system. As long as we're fine with this organizationally, this is purely an access issue.
Assignee: nobody → server-ops
Component: Release Engineering → Server Operations
QA Contact: release → mrz
(Assignee)

Updated

8 years ago
Assignee: server-ops → thardcastle
(Assignee)

Updated

8 years ago
Attachment #418497 - Attachment mime type: application/octet-stream → text/plain
(Assignee)

Comment 4

8 years ago
wr@dm-symbolpush01.mozilla.org:/mnt/netapp/breakpad/symbols_opensuse/ using the public key attached should allow uploads now. I still need to add the processor configuration.
(Assignee)

Comment 5

8 years ago
Processor configuration update and processors restarted.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
Hmm, cannot authenticate apparently. Not quite sure why.
Could you please check?

Hygiea:~/.ssh> ssh -v -i ~/.ssh/id_rsa_mozsymbols wr@dm-symbolpush01.mozilla.org
OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009
debug1: Reading configuration data .ssh/config
debug1: Applying options for mozsymbols
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to dm-symbolpush01.mozilla.org [63.245.208.163] port 22.
debug1: Connection established.
debug1: identity file .ssh/id_rsa_mozsymbols type 1
debug1: identity file .ssh/id_rsa_mozsymbols type 1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
debug1: match: OpenSSH_5.2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'dm-symbolpush01.mozilla.org' is known and matches the RSA host key.
debug1: Found key in .ssh/known_hosts:66
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Next authentication method: publickey
debug1: Offering public key: .ssh/id_rsa
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Offering public key: .ssh/id_rsa_mozsymbols
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Offering public key: .ssh/id_rsa_mozsymbols
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: No more authentication methods to try.
Permission denied (publickey,gssapi-with-mic).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

8 years ago
(In reply to comment #6)
> Hmm, cannot authenticate apparently. Not quite sure why.
> Could you please check?

Seems I missed a second group you need. Try it now?
(Reporter)

Comment 8

8 years ago
Thanks, working now.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Will this be for nightly symbols as well as release ?
(Reporter)

Comment 10

8 years ago
For a mixture ;-)
We don't have "nightly" builds but we often have several builds for one version over time (if there are changes in packaging or patches we apply or rebuilds caused by a change to an underlying subsystem). Also there are extra builds for every supported distribution. The exact set what is planned to transfer is not set in stone yet.
Ok. I was asking from the point of view of cleaning up old nightly symbols to keep disk usage under control. If it gets out of hand we can revisit in the future.
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.