Empty message header - Functionality (usually Buttons) not appearing or available

RESOLVED INCOMPLETE

Status

Thunderbird
Message Reader UI
--
major
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: leroy_tennison, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-10-01)

Attachments

(10 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

Most common is message pane issues (on both OpenSuSE 11.2 and Debian 5.0.3).  On some messages (all of them "old" in the sense that they had been received prior to upgrade) the Reply/Forward/Archive/Junk/Delete buttons appear and work.  On others they aren't there (not just invisible - clicking where they should be produces no action).  I haven't been able to identify any further commonality.  Deleting old messages doesn't cause additional ones to have button functionality, sorting messages doesn't seem to have any impact, it's not just a contiguous range either.

On one occasion so far the subject lines for four messages disappeared and I couldn't open them by clicking on them (they were in the middle of my Inbox).  Exiting Thunderbird and restarting it solved that problem.

Reproducible: Always



Expected Results:  
Buttons should appear and be active for each mail message.

If you feel it would be beneficial I can forward a couple of emails where the buttons appear and a couple where they don't.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0

Comment 1

8 years ago
are you using default theme?
can you reproduce with thunderbird started in safe mode.
can you attach screen shot?
is this both in message preview (3 pane window) and standalone display?
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader
(Reporter)

Comment 2

8 years ago
Created attachment 418779 [details]
A message with buttons present
(Reporter)

Comment 3

8 years ago
Created attachment 418781 [details]
Message with buttons missing, the header is at it's top position, note "From" not visible
(Reporter)

Comment 4

8 years ago
Created attachment 418782 [details]
Same message as TB3-b.png but header scrolled to see "From"
(Reporter)

Comment 5

8 years ago
Created attachment 418784 [details]
Message in TB3-a.png opened in a separate tab
(Reporter)

Comment 6

8 years ago
Created attachment 418785 [details]
Message in TB3-c.png opened in a separate tab
(Reporter)

Comment 7

8 years ago
Created attachment 418786 [details]
Same message at TB3-a.png, proof we're in safe mode
(Reporter)

Comment 8

8 years ago
Created attachment 418787 [details]
Same message at TB3-c.png, proof we're in safe mode
(Reporter)

Comment 9

8 years ago
Created attachment 418791 [details]
Current xorg.conf

Right now I have 38 messages in my Inbox.  1-5 and 7 have buttons, the rest don't.
(Reporter)

Comment 10

8 years ago
Created attachment 418792 [details]
Messages blanked out

Wasn't expecting to be able to document this but it happened again.  I happened to click the "Sort by junk status" button and several messages blanked out.  I also couldn't open them.  All 38 Inbox messages have subject lines.  I exited Thunderbird and restarted it (again in safe mode) and all 38 messages showed a subject line and the three I opened contained the original message.
(Reporter)

Comment 11

8 years ago
If you need anything else please let me know.  Again, thanks for your effort on this.
So do you have the issue in safe-mode (http://kb.mozillazine.org/Safe_mode) ?

Anuything in Tools -> Error console when this happens ?

Comment 13

8 years ago
dup of bug 526918?
Summary: Functionality (usually Buttons) not appearing or available → Empty message header - Functionality (usually Buttons) not appearing or available
(In reply to comment #13)
> dup of bug 526918?

I agree too (it seems closely the same behavior). 
Feel free to reopen it if I'm wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526918
(Reporter)

Comment 15

8 years ago
Created attachment 419089 [details]
Question about Error Console

I found an error message in Error Console but I had been doing a number of things (reading/deleting messages) so I wanted a "clean state".  As a result I opened your message in a new tab then exited Thunderbird.  After re-launching it I opened the Error Console, that is what the attachment represents.
(Reporter)

Comment 16

8 years ago
I looked at bug 526918 and am unsure of the duplicate status.  That bug talks about varying space in the header causing someone to have to scroll to get to the content but some of the screen shots show the problem I am reporting (no buttons in the header).  Rethinking this, there are three problems here, maybe we need to open bugs for each.  The three problems I see are:

Excess leading space in the header causing it to need to be scrolled (bug 526918)

No buttons in the header (this bug unless you want to consider that a part of bug 526918.  If so then it reports two separate issues, the one above and this one.)  It doesn't matter to me how you want to handle it, just let me know.

Subject lines in the message list "blanking out" which also has the effect that the message can't be opened and it won't display in the reading pane.  This is comment 10 above.  I had this happen again tonight while working on replying only this time it happened after deleting a message (the messages below the deleted one blanked out).  I now realize that my bug is actually two separate issues.

My suggestion would be to create three separate bugs (those above) out of these two in order to avoid confusion about what needed to be fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 17

8 years ago
One other comment, it seems that there is a patch for at least some of this.  Would it be easy for me to incorporate in my Thunderbird 3 installation?  If so I'd be glad to download it (just tell me where to get it and what to do with it) and test.  If it fixed something that might be helpful in simplifying things.  Let me know.
(Reporter)

Comment 18

8 years ago
More information about the "disappearing list entries" part of this bug.  I noticed tonight that, once an entry in the list "went blank", as I moved my mouse over other entries they went blank as well.  I also discovered that I didn't have to exit Thunderbird to "recover", I switched focus away from the list to an email and, when I returned, the blank entries now appeared again.  Hope some of this helps find the source of the issue.

Comment 19

8 years ago
do you see this in v3.1?  And if so, please recap by supplying a set of numbered steps (actions) to reproduce the problem.
Whiteboard: closeme 2010-10-01
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.