If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Having a few channel open but wanting to join auto-connect channels

RESOLVED WONTFIX

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: dynvec, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Build Identifier: ChatZilla 0.9.86 [Firefox 3.5.6/20091201220228]

This issue (I wouldn't call an enhancement request a bug) is related to the issue 299448 as I have a lot of auto-connect channel and servers so I sometime search for a specific topic then connect to ask a question but it can happen that an answer doesn't come within a reasonable delay (30 minutes) so I get bored and I want to read my usuals but can't open another ChatZilla instance so I'd have to close the current one then reopen it risking to miss the precious answer.

My suggestion is to add a Join (connect) button in the preferences window below the remove button and that double-clicking a channel would join it.

Reproducible: Always

Steps to Reproduce:
1. Join a channel through irc://
2. Desire to join auto-connect channels
Actual Results:  
Nothing.  ATM, you'd need to remember all the channel/server or maintain a list to achieve the goal.

Expected Results:  
Joining channels through the list in Preferences.

Thank you kindly for considering my request.

Comment 1

8 years ago
This would be suited best by an alias, such as this one:

/alias startup evals processStartupURLs()

You can then do /startup to open the inital URLs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> This would be suited best by an alias, such as this one:
> 
> /alias startup evals processStartupURLs()
> 
> You can then do /startup to open the inital URLs.

I entered "/alias startup evals processStartupURLs()" then had the message "[INFO]	Created alias: startup = evals processStartupURLs()." but then entering "/startup" does nothing ...  Was that a workaround or a modified proposition ?

Please forgive my ignorange but why was the issue flagged with WONTFIX ?

Comment 3

8 years ago
The bug has been marked wontfix, because this is a feature that will not be implemented directly into ChatZilla.

The alias I provided works fine for me here, try making it "eval processStartupURLs()" and then you should get some feedback if something is going wrong (evals is short for evalsilent, which doesn't give feedback)
(Reporter)

Comment 4

8 years ago
I hope I'm not derailing the thread by now asking for troubleshooting.

After typing "/eval processStartupURLs()" I get the following :
[EVAL-IN]	processStartupURLs()
[EVAL-OUT]	undefined

It still won't load my auto-connect channels.  :(
Thanks for the help.

Comment 5

8 years ago
My mistake, it appears that processStartupURLs() is smarter than I thought, and wont try to load your startup URLs if ChatZilla was started in a way that wouldn't have loaded them.

Try this one instead:
/alias startup evals for (var i = 0\; i < client.prefs["initialURLs"].length\; ++i) { gotoIRCURL(client.prefs["initialURLs"][i]) }
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> Try this one instead:
> /alias startup evals for (var i = 0\; i < client.prefs["initialURLs"].length\;
> ++i) { gotoIRCURL(client.prefs["initialURLs"][i]) }

Yes !  Thank you very much.  :)
You need to log in before you can comment on or make changes to this bug.