Disable Filterset.G Updater extension

VERIFIED FIXED in 5.6

Status

addons.mozilla.org Graveyard
Administration
P3
minor
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: Wladimir Palant (for Adblock Plus info Cc bugzilla@adblockplus.org), Assigned: jorgev)

Tracking

unspecified

Details

(URL)

Attachments

(1 attachment)

I was considering removing Adblock Plus code that warns users who have Filterset.G Updater extension installed. However, when I looked on AMO I noticed that Filterset.G Updater is still active - and I bet that it is still being downloaded despite all the warnings. This extension is unmaintained and the server it downloads filters from (pierceive.com/filtersetg.com) is gone. Even if the extension stays "for historical reasons", it should be at least sandboxed.
Ah, I don't need to guess, the statistics are public - roughly 400 downloads per day and still 250k active daily users. Ouch...
Uhm, it feels to me like we've sandboxed this before? :( Jorge, welcome back from vacation ;)
Assignee: nobody → jorge
Priority: -- → P2
Target Milestone: --- → 5.5
(Assignee)

Comment 3

8 years ago
There's a thread in the amo-editors mailing list about this. The Updater add-on has an update for its latest version that does nothing more than remove itself. I don't know if it has been approved or not.

Publishing this update would help reduce the numbers significantly before sandboxing or disabling the add-on.
Heh, my fault: bug 497377
So, apparently this is the fake update being available for download there?
Confirmed, version 0.5 simply uninstalls itself and version 0.5.1 currently in queue is the same thing without OS X specific (unnecessary) files. The 250k active daily users are mostly ones who chose not to update.
(Assignee)

Comment 6

8 years ago
Pushing to a future milestone to check the stats then.
Severity: normal → minor
Priority: P2 → P3
Target Milestone: 5.5 → 5.6
Created attachment 418858 [details]
Applications used by Filterset.G Updater users

Pulled the application stats from AMO - 60% Firefox 3.0 and 20% Firefox 2, oh my... I guess that's not the update-friendly part of the user base.
We sent out the uninstaller earlier this year (July maybe?) and I kept the add-on public so that the update would go out to users. It dropped a few hundred thousand ADU, but I don't think it's going to get any lower. Last I looked, there were a decent number of people that actually had the uninstaller version installed.

We mainly did the uninstaller update because of Firefox 3.5 compatibility. So, I'm fine with disabling the add-on again or keeping it up. I don't think ADU is going to get any lower though.
What needs to happen here?
(Assignee)

Comment 10

8 years ago
We wait. On the 5.6 timeline I will review the stats for the add-on and decide if the add-on should be disabled.
(Assignee)

Comment 11

8 years ago
I've disabled it.

For whatever reason there's a recent increase in users (270K+ ADU). The majority seem to be using an old version (3.1.3), with Firefox 3.0.*. Better not make it available anymore.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
I can find that the add-on is successfully disabled and cannot be found on AMO anymore. 

However, there's still https://preview.addons.mozilla.org/en-US/firefox/addon/1136. Do we disable that, too?
Status: RESOLVED → VERIFIED
(Assignee)

Comment 13

8 years ago
Done.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.