Mozilla fails to start, infinite loop

VERIFIED DUPLICATE of bug 42184

Status

()

Core
Networking
P3
blocker
VERIFIED DUPLICATE of bug 42184
18 years ago
18 years ago

People

(Reporter: Hal Burgiss, Assigned: Warren Harris)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Starting maybe a week ago, I am unable
to start any of the nightly builds for 
Linux. The program starts to load, then 
appears to hang. Strace shows an 
infinite loop with gettimeofday(). 

poll([{fd=12, events=POLLIN}, {fd=13, events=POLLIN}, {fd=5, events=POLLIN}], 3,
9) = 0
gettimeofday({969552414, 880317}, NULL) = 0
gettimeofday({969552414, 880453}, NULL) = 0
ioctl(12, FIONREAD, [0])                = 0
poll([{fd=12, events=POLLIN}, {fd=13, events=POLLIN}, {fd=5, events=POLLIN}], 3,
0) = 0
gettimeofday({969552414, 880908}, NULL) = 0
ioctl(12, FIONREAD, [0])                = 0
poll([{fd=12, events=POLLIN}, {fd=13, events=POLLIN}, {fd=5, events=POLLIN}], 3,
9) = 0
gettimeofday({969552414, 900542}, NULL) = 0
gettimeofday({969552414, 900689}, NULL) = 0
ioctl(12, FIONREAD, [0])                = 0
poll([{fd=12, events=POLLIN}, {fd=13, events=POLLIN}, {fd=5, events=POLLIN}], 3,
0) = 0
gettimeofday({969552414, 901126}, NULL) = 0
ioctl(12, FIONREAD, [0])                = 0
poll([{fd=12, events=POLLIN}, {fd=13, events=POLLIN}, {fd=5, events=POLLIN}], 3,
9) = 0
gettimeofday({969552414, 920313}, NULL) = 0
gettimeofday({969552414, 920462}, NULL) = 0
ioctl(12, FIONREAD, [0])                = 0


ad infinitum. Mozilla-bin has to be 
manually killed.

I start with a clean tree each day, and 
tried removing ~/.mozilla. The system 
is RH6.2 Intel (updated) SMP (wild hunch 
this is a factor). Until this point, the 
nightlies were doing just fine. I have 
tried nightlies pretty much everyday
during this period, including today (9-21).

hal@feenix hal]$ procinfo
Linux 2.2.16pre3 (root@feenix) (gcc egcs-2.91.66) #1 2CPU [feenix.]
Memory:      Total        Used        Free      Shared     Buffers      Cached
Mem:        128176      115084       13092       51384        2884       29484
Swap:       190592       71372      119220
Bootup: Wed May 17 19:40:49 2000    Load average: 0.09 0.06 0.02 7/95 7733
user  :   5d  6:15:14.02   2.0%  page in : 52948884  disk 1:   457134r   96699w
nice  :       0:00:10.86   0.0%  page out: 25763749  disk 2:   531138r 1833967w
system:   7d  7:58:17.35   2.9%  swap in :  5205856  disk 3:  8342603r 7463311w
idle  : 241d  8:45:07.01  95.0%  swap out:  1264101
uptime: 126d 23:29:24.60         context :3969318336
irq  0:1097096462 timer                 irq  9:  11403832 eth0
irq  1:  13961249 keyboard              irq 10:     93048 eth1
irq  2:         0 cascade [4]           irq 11:     33165 ide2
irq  4:    238230                       irq 12:  22918783 PS/2 Mouse
irq  5:    342887 soundblaster          irq 13:         1 fpu
irq  6:     28501                       irq 14:   2869773 ide0
irq  8:       515 rtc                   irq 15:  15687021 ide1

Comment 1

18 years ago
maybe bug 52111.  over to waren.
Assignee: asa → warren
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
(Reporter)

Comment 2

18 years ago
After looking at the possibly related bug report, I'll add that my glibc version
is currently glibc-2.1.3-21, though had the same situation with whatever the 
shipped version is with RH6.2. I would also note that this happens with 
*every* attempt to start Mozilla. HTH
(Assignee)

Comment 3

18 years ago
What's the failure you get in the log file as you start up? (Just include the 
entire long). 

Also, this isn't an infinite loop -- your chrome just failed to load leaving 
you with no window. 
(Reporter)

Comment 4

18 years ago
Sorry to be clueless, for cannot find a log file for the life of me. Nor 
any references to one in FAQ or elsewhere. The best I can get is program 
output:

wait4(-1, MOZILLA_FIVE_HOME=/usr/lib/mozilla
  LD_LIBRARY_PATH=/usr/lib/mozilla
     LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/components
       SHLIB_PATH=/usr/lib/mozilla
          LIBPATH=/usr/lib/mozilla
       ADDON_PATH=/usr/lib/mozilla
      MOZ_PROGRAM=/usr/lib/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=

And hangs here. Glady give more info if you can point me a bit in the right 
direction. TIA

(Assignee)

Comment 5

18 years ago
I'm talking about the program output when it starts up. Usually you see a bunch 
of messages about registering components, then stuff about registering chrome, 
etc. Are you running a debug build? Try touching your 
dist/bin/installed-chrome.txt file first and re-launching.
(Reporter)

Comment 6

18 years ago
This is the grand total of output I get:

[hal@feenix mozilla]$ ./mozilla
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=

Stops right there. Tried touching installed-chrome.txt. I am running 
mozilla-i686-pc-linux-gnu.tar.gz. Latest was yesterday's.
(Assignee)

Comment 7

18 years ago
I don't know -- is that a debug build? I can only suggest you try running it in 
the debugger and seeing where it hangs since we don't have that problem here.
(Reporter)

Comment 8

18 years ago
Well I hope I am not wasting anybody's time with this. I keep looking over my 
should to see if I am doing something really stupid. Anyway AFAICT the 
nightly binaries have no debugging support, so I dl'd the nightly source and 
built that yesterday. Did not run either at first, then deleted ~/.mozilla, 
and bingo! it ran. 

Then tried the nightly binary (from 2 days ago) which had been a no go, and it
ran too. Used it yesterday and today no problem. Really coming along great BTW.
Presumably .mozilla was the problem, though I know I had tried deleting this
before. 

So anyway today, I decide to try the latest nightly binary, and back to square 
one. Will not run. Hangs just after starting with I guess no useful output.
Deleting ~/.mozilla is not doing any good. I redownloaded thinking maybe I 
got a corrupted something or other on the way. But still no go. The built source
from yesterday still does run however. So I am lost I guess at this point since
I can't get any useful output from the nightly binaries. Is there something
besides ~/.mozilla that might be munging things? I've looked and don't see
anything.

Sorry to be a bother.

Comment 9

18 years ago
if you install... you have to run moz once as root before running as a normal
user. A handful files and directories are created. Can this be the problem?
(Reporter)

Comment 10

18 years ago
Yes, Kristen, this seems to do the trick, thanks. Is this something new, or have 
I just been lucky in the past by not doing this?
(Assignee)

Comment 11

18 years ago

*** This bug has been marked as a duplicate of 42184 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.