Closed Bug 536403 Opened 10 years ago Closed 10 years ago

Mousewheel scrolling gets stuck on embedded YouTube video

Categories

(Firefox :: General, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 483136

People

(Reporter: notforyourmail, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20091222 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20091222 Minefield/3.7a1pre

I've gotten stuck on scrolling on several sites over the past few days.  This one demonstrates the problem clearly:

http://technologizer.com/2009/12/20/dumb-moments/3/

I'm using an Apple Mighty Mouse (found on all desktop Macs sold for the past 4 years or so, until a few months ago), and scrolling using the scroll ball on the mouse.  Scrolling using the scroll bar, page down, space bar, or arrow keys works fine.  The window stops scrolling when I hit on Steve Jobs in item number 37 (below "And yet Apple inexplicably continued with plans for the iPhone.")  If the mouse pointer is above that video, then scrolling will fail as soon as the video is below the mouse pointer.  If the video does NOT cross below the mouse pointer during the scroll, scrolling works fine.  In other words, the video is somehow disrupting scrollability.

the video Note: must click on the 

Reproducible: Always

Steps to Reproduce:
1. Go to http://technologizer.com/2009/12/20/dumb-moments/3/
2. Place Might Mouse mouse pointer above the video in #37.  (Also works if below it.)
3. Scroll up or down using the scroll ball so that the video crosses below the pointer.
4. Page scrolling stops completely when the video is below the pointer.
5. Move the pointer out of the scroll path of the video
6. Scrolling works fine.
Actual Results:  
Scrolling suddenly fails if the mouse pointer is above the video.  Scrolling works when the pointer is not above the video.

Expected Results:  
Scrolling works all the time.
Note: this is also reproducible in Safari.
Whiteboard: [DUPEME]
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME]
Duplicate of bug: 483136
You need to log in before you can comment on or make changes to this bug.