Closed Bug 536407 Opened 11 years ago Closed 10 years ago

when building profiles, stop copying files to the application directory, use the profile

Categories

(Testing :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 543800

People

(Reporter: jmaher, Unassigned)

References

Details

Attachments

(3 files)

We should be able to copy all extensions and preferences to the profile directory instead of pushing stuff into the application directory.

Fix the harnesses (mochitest, reftest, automation.py) to only use the profile directory for test specific bits.  This includes all the extensions we use for chrome style testing.
Depends on: 530475
Comment on attachment 427773 [details] [diff] [review]
Used the PROFILE_DIRECTORY variable for storing the file in profile

ted, really small patch here if you can take a look at it.
Attachment #427773 - Flags: review?(ted.mielczarek)
Comment on attachment 427773 [details] [diff] [review]
Used the PROFILE_DIRECTORY variable for storing the file in profile

actually further testing of this patch resulted in a failure to run. 

adifire: you are joining profile_directory, chrome, file.  The probile is file is not defined.  I believe we just need to join profile_directory and chrome.  Please make these changes and test on your local system with mochitests.
Attachment #427773 - Flags: review?(ted.mielczarek) → review-
Joel: Now I tried it in my local server and it's working.
So this patch just creates the mochikit.manifest file in the profile instead of the application directory.

One problem is that when the browser tries to load up chrome://mochikit/<path>/<file>, it just hangs there.  

Is there anything else we need to do in order to get this to recognize the mochikit.manifest?  A different location, a separate file?
As a side effect of bug 543800 we will be running everything out of the profile directory.  The trick is to build a real extension, not just a .manifest file.  Marking as a duplicate since this problem will be solved.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543800
You need to log in before you can comment on or make changes to this bug.