Filtering is not working with non-ascii chars in mail body

VERIFIED FIXED

Status

MailNews Core
Internationalization
P2
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: marina, Assigned: Takayuki Tei)

Tracking

({intl})

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:
- create a filter with non-ascii char in the body;
- send message with this string;
//note: you still getting the message in your Inbox instead of a selected folder

Comment 1

18 years ago
Reassign to alecf.
I think this was blocked by the crasher.
Assignee: nhotta → alecf

Comment 2

18 years ago
Who will be doing mail QA in Kat's absense?

Comment 3

18 years ago
>Who will be doing mail QA in Kat's absense?
ji and marina


Comment 4

18 years ago
changing QA contact to marina
QA Contact: momoi → marina

Comment 5

18 years ago
On today's builds, I don't see "Body" in the drop list of criteria definition.
Is filtering by mail body taken out?
(Reporter)

Comment 6

18 years ago
i DO see it in my build on Win NT (using old profile)

Comment 7

17 years ago
reassign to bienvenu, add taka to CC in case he wants to take this one.
Assignee: alecf → bienvenu

Comment 8

17 years ago
adding mail3 keyword
Keywords: mail3

Comment 9

17 years ago
Adding jenm to cc: list.

Comment 10

17 years ago
changing priorities
Priority: P3 → P2

Updated

17 years ago
Keywords: intl

Comment 11

17 years ago
marking nsbeta1-
Keywords: nsbeta1-

Comment 12

17 years ago
removing myself from cc: list.

Comment 13

17 years ago
what was the criteria to mark it nsbeta1-? 
(Assignee)

Comment 14

17 years ago
The cause of this bug must be the same as #43221.
I take over this since my fix for #43221 will fix this too
once I'm allowed to check it in.
Assignee: bienvenu → taka
(Assignee)

Comment 15

17 years ago
add bienvenu and mscott to cc list.
Status: NEW → ASSIGNED

Comment 16

17 years ago
I already sr'd the other bug.
(Assignee)

Comment 17

17 years ago
checked in.  r=nhotta, a=sr=bienvenu
mark as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

17 years ago
verified with 2001-01-31 mtrunk build, filtering by body is working correctly (
tested POP3 only because filtering by body doesn't apply to imap)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.