Closed Bug 536441 Opened 10 years ago Closed 10 years ago

Crash [@ ElementTransitionsPropertyDtor] on Tinderbox after unit-rem-div-fontsize.html (unit-rem-div-width-inner.html?)

Categories

(Core :: General, defect)

Other Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 536382

People

(Reporter: benjamin, Unassigned)

Details

OS X 10.5.2 mozilla-central opt test everythingelse on 2009/12/22 10:54:50
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261508090.1261510217.13283.gz

REFTEST TEST-PASS | file:///builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/reftest/tests/layout/reftests/css-valuesandunits/unit-rem-div-fontsize.html |
TEST-UNEXPECTED-FAIL | automation.py | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:04:03.717444
INFO | automation.py | Reading PID log: /var/folders/TL/TLg3RrMbFAur2hBCXvCeqk+++TM/-Tmp-/tmpSFbdMspidlog
TEST-UNEXPECTED-FAIL | automation.py | application crashed (minidump found)
Operating system: Mac OS X
                  10.5.2 9C31
CPU: x86
     GenuineIntel family 6 model 15 stepping 2
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE
Crash address: 0x20

Thread 0 (crashed)
 0  XUL!ElementTransitionsPropertyDtor [nsTransitionManager.cpp:10050c1a0b32 : 936 + 0x12]
    eip = 0x02203a5a   esp = 0xbfffbf60   ebp = 0xbfffbf98   ebx = 0x022021fe
    esi = 0x07172a70   edi = 0x07172a74   eax = 0x00000000   ecx = 0x07172a50
    edx = 0x0d3e9530   efl = 0x00210246
    Found by: given as instruction pointer in context
 1  XUL!nsPropertyTable::DeleteProperty(nsPropertyOwner, unsigned short, nsIAtom*) [nsPropertyTable.cpp:10050c1a0b32 : 361 + 0x1b]
    eip = 0x022d3d60   esp = 0xbfffbfa0   ebp = 0xbfffbfc8
    Found by: previous frame's frame pointer
 2  XUL!nsINode::DeleteProperty(unsigned short, nsIAtom*) [nsGenericElement.cpp:10050c1a0b32 : 243 + 0x1f]
    eip = 0x022b4350   esp = 0xbfffbfd0   ebp = 0xbfffbff8
    Found by: previous frame's frame pointer
 3  XUL!nsTransitionManager::Release() [mozilla-central::10050c1a0b32 : 541 + 0x16]
    eip = 0x0220225a   esp = 0xbfffc000   ebp = 0xbfffc038
    Found by: previous frame's frame pointer
 4  XUL + 0x24f2cd
    eip = 0x020cd2ce   esp = 0xbfffc040   ebp = 0xbfffc098
    Found by: previous frame's frame pointer
 5  XUL + 0x24f331
    eip = 0x020cd332   esp = 0xbfffc0a0   ebp = 0xbfffc0b8
    Found by: previous frame's frame pointer
 6  XUL!nsPresContext::Release() [nsPresContext.cpp:10050c1a0b32 : 331 + 0xa]
    eip = 0x020c869c   esp = 0xbfffc0c0   ebp = 0xbfffc0d8
    Found by: previous frame's frame pointer
 7  XUL!nsCOMPtr_base::assign_with_AddRef(nsISupports*) [nsCOMPtr.h:10050c1a0b32 : 456 + 0x7]
    eip = 0x029b8e4c   esp = 0xbfffc0e0   ebp = 0xbfffc0f8
    Found by: previous frame's frame pointer
 8  XUL!DocumentViewerImpl::Destroy() [mozilla-central::10050c1a0b32 : 640 + 0x9]
    eip = 0x020b7e42   esp = 0xbfffc100   ebp = 0xbfffc168
    Found by: previous frame's frame pointer
 9  XUL!nsSHistory::EvictContentViewersInRange(int, int) [nsSHistory.cpp:10050c1a0b32 : 881 + 0x7]
    eip = 0x027772cc   esp = 0xbfffc170   ebp = 0xbfffc1b8
    Found by: previous frame's frame pointer
10  XUL!nsSHistory::EvictContentViewers(int, int) [nsSHistory.cpp:10050c1a0b32 : 848 + 0x12]
    eip = 0x02778f19   esp = 0xbfffc1c0   ebp = 0xbfffc1d8
    Found by: previous frame's frame pointer
11  XUL!DocumentViewerImpl::Show() [nsDocumentViewer.cpp:10050c1a0b32 : 1937 + 0x15]
    eip = 0x020b8d69   esp = 0xbfffc1e0   ebp = 0xbfffc278
    Found by: previous frame's frame pointer
12  XUL!nsPresContext::EnsureVisible() [nsPresContext.cpp:10050c1a0b32 : 1612 + 0x7]
    eip = 0x020c8b4b   esp = 0xbfffc280   ebp = 0xbfffc2d8
    Found by: previous frame's frame pointer
13  XUL!PresShell::UnsuppressAndInvalidate() [nsPresShell.cpp:10050c1a0b32 : 4553 + 0xa]
    eip = 0x020cea16   esp = 0xbfffc2e0   ebp = 0xbfffc308
    Found by: previous frame's frame pointer
14  XUL!PresShell::UnsuppressPainting() [nsPresShell.cpp:10050c1a0b32 : 4599 + 0x7]
    eip = 0x020cf6a8   esp = 0xbfffc310   ebp = 0xbfffc328
    Found by: previous frame's frame pointer
15  XUL!DocumentViewerImpl::LoadComplete(unsigned int) [nsDocumentViewer.cpp:10050c1a0b32 : 1083 + 0xa]
    eip = 0x020b7529   esp = 0xbfffc330   ebp = 0xbfffc3a8
    Found by: previous frame's frame pointer
16  XUL!nsDocShell::EndPageLoad(nsIWebProgress*, nsIChannel*, unsigned int) [nsDocShell.cpp:10050c1a0b32 : 5735 + 0xe]
    eip = 0x0274da9a   esp = 0xbfffc3b0   ebp = 0xbfffc658
    Found by: previous frame's frame pointer
17  XUL!nsDocShell::OnStateChange(nsIWebProgress*, nsIRequest*, unsigned int, unsigned int) [nsDocShell.cpp:10050c1a0b32 : 5613 + 0x25]
    eip = 0x0274b504   esp = 0xbfffc660   ebp = 0xbfffc6d8
    Found by: previous frame's frame pointer
18  XUL!nsDocLoader::FireOnStateChange(nsIWebProgress*, nsIRequest*, int, unsigned int) [nsDocLoader.cpp:10050c1a0b32 : 1314 + 0x23]
    eip = 0x0275fc91   esp = 0xbfffc6e0   ebp = 0xbfffc748
    Found by: previous frame's frame pointer
19  XUL!nsDocLoader::DocLoaderIsEmpty(int) [nsDocLoader.cpp:10050c1a0b32 : 926 + 0x21]
    eip = 0x0276134b   esp = 0xbfffc750   ebp = 0xbfffc7f8
    Found by: previous frame's frame pointer
20  XUL!nsDocLoader::OnStopRequest(nsIRequest*, nsISupports*, unsigned int) [nsDocLoader.cpp:10050c1a0b32 : 697 + 0xf]
    eip = 0x027616ec   esp = 0xbfffc800   ebp = 0xbfffc868
    Found by: previous frame's frame pointer
21  XUL!nsLoadGroup::RemoveRequest(nsIRequest*, nsISupports*, unsigned int) [nsLoadGroup.cpp:10050c1a0b32 : 680 + 0x19]
    eip = 0x01f36a50   esp = 0xbfffc870   ebp = 0xbfffc8c8
    Found by: previous frame's frame pointer
22  XUL!nsDocument::UnblockOnload(int) [nsDocument.cpp:10050c1a0b32 : 7117 + 0x21]
    eip = 0x022a18dd   esp = 0xbfffc8d0   ebp = 0xbfffc8f8
    Found by: previous frame's frame pointer
23  XUL!nsDocument::DispatchContentLoadedEvents() [nsDocument.cpp:10050c1a0b32 : 4037 + 0x15]
    eip = 0x022a013d   esp = 0xbfffc900   ebp = 0xbfffc9c8
    Found by: previous frame's frame pointer
24  XUL!nsRunnableMethod<nsDocument, void>::Run() [nsThreadUtils.h : 282 + 0xf]
    eip = 0x022a60d1   esp = 0xbfffc9d0   ebp = 0xbfffc9e8
    Found by: previous frame's frame pointer
25  XUL!nsThread::ProcessNextEvent(int, int*) [nsThread.cpp:10050c1a0b32 : 527 + 0x7]
    eip = 0x029fd64c   esp = 0xbfffc9f0   ebp = 0xbfffca38
    Found by: previous frame's frame pointer
26  XUL!NS_ProcessPendingEvents_P(nsIThread*, unsigned int) [nsThreadUtils.cpp : 200 + 0x16]
    eip = 0x029be1c7   esp = 0xbfffca40   ebp = 0xbfffca88
    Found by: previous frame's frame pointer
27  XUL!nsBaseAppShell::NativeEventCallback() [nsBaseAppShell.cpp:10050c1a0b32 : 125 + 0x1a]
    eip = 0x0296d442   esp = 0xbfffca90   ebp = 0xbfffcab8
    Found by: previous frame's frame pointer
28  XUL!nsAppShell::ProcessGeckoEvents(void*) [nsAppShell.mm:10050c1a0b32 : 510 + 0x7]
    eip = 0x02933af8   esp = 0xbfffcac0   ebp = 0xbfffcb98
    Found by: previous frame's frame pointer
29  CoreFoundation + 0x7262d
    eip = 0x9596c62e   esp = 0xbfffcba0   ebp = 0xbfffd158
    Found by: previous frame's frame pointer
30  CoreFoundation + 0x72d17
    eip = 0x9596cd18   esp = 0xbfffd160   ebp = 0xbfffd198
    Found by: previous frame's frame pointer
31  HIToolbox + 0x3069f
    eip = 0x954196a0   esp = 0xbfffd1a0   ebp = 0xbfffd1d8
    Found by: previous frame's frame pointer
32  HIToolbox + 0x303f1
    eip = 0x954193f2   esp = 0xbfffd1e0   ebp = 0xbfffd268
    Found by: previous frame's frame pointer
33  HIToolbox + 0x3032c
    eip = 0x9541932d   esp = 0xbfffd270   ebp = 0xbfffd288
    Found by: previous frame's frame pointer
34  AppKit + 0x407d8
    eip = 0x92a147d9   esp = 0xbfffd290   ebp = 0xbfffd5f8
    Found by: previous frame's frame pointer
35  AppKit + 0x4008d
    eip = 0x92a1408e   esp = 0xbfffd600   ebp = 0xbfffd8f8
    Found by: previous frame's frame pointer
36  XUL!nsAppShell::ProcessNextNativeEvent(int) [nsAppShell.mm:10050c1a0b32 : 792 + 0x3b]
    eip = 0x02934da1   esp = 0xbfffd900   ebp = 0xbfffd9d8
    Found by: previous frame's frame pointer
37  XUL!nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal*, int, unsigned int) [nsBaseAppShell.cpp:10050c1a0b32 : 155 + 0xf]
    eip = 0x0296d7f5   esp = 0xbfffd9e0   ebp = 0xbfffda18
    Found by: previous frame's frame pointer
38  XUL!nsAppShell::OnProcessNextEvent(nsIThreadInternal*, int, unsigned int) [nsAppShell.mm:10050c1a0b32 : 950 + 0x1f]
    eip = 0x02933395   esp = 0xbfffda20   ebp = 0xbfffdaa8
    Found by: previous frame's frame pointer
39  XUL!nsThread::ProcessNextEvent(int, int*) [nsThread.cpp:10050c1a0b32 : 508 + 0x24]
    eip = 0x029fd5f1   esp = 0xbfffdab0   ebp = 0xbfffdaf8
    Found by: previous frame's frame pointer
40  XUL!NS_ProcessPendingEvents_P(nsIThread*, unsigned int) [nsThreadUtils.cpp : 200 + 0x16]
    eip = 0x029be1c7   esp = 0xbfffdb00   ebp = 0xbfffdb48
    Found by: previous frame's frame pointer
41  XUL!nsBaseAppShell::NativeEventCallback() [nsBaseAppShell.cpp:10050c1a0b32 : 125 + 0x1a]
    eip = 0x0296d442   esp = 0xbfffdb50   ebp = 0xbfffdb78
    Found by: previous frame's frame pointer
42  XUL!nsAppShell::ProcessGeckoEvents(void*) [nsAppShell.mm:10050c1a0b32 : 510 + 0x7]
    eip = 0x02933af8   esp = 0xbfffdb80   ebp = 0xbfffdc58
    Found by: previous frame's frame pointer
43  CoreFoundation + 0x7262d
    eip = 0x9596c62e   esp = 0xbfffdc60   ebp = 0xbfffe218
    Found by: previous frame's frame pointer
44  CoreFoundation + 0x72d17
    eip = 0x9596cd18   esp = 0xbfffe220   ebp = 0xbfffe258
    Found by: previous frame's frame pointer
45  HIToolbox + 0x3069f
    eip = 0x954196a0   esp = 0xbfffe260   ebp = 0xbfffe298
    Found by: previous frame's frame pointer
46  HIToolbox + 0x303f1
    eip = 0x954193f2   esp = 0xbfffe2a0   ebp = 0xbfffe328
    Found by: previous frame's frame pointer
47  HIToolbox + 0x3032c
    eip = 0x9541932d   esp = 0xbfffe330   ebp = 0xbfffe348
    Found by: previous frame's frame pointer
48  AppKit + 0x407d8
    eip = 0x92a147d9   esp = 0xbfffe350   ebp = 0xbfffe6b8
    Found by: previous frame's frame pointer
49  AppKit + 0x4008d
    eip = 0x92a1408e   esp = 0xbfffe6c0   ebp = 0xbfffe9b8
    Found by: previous frame's frame pointer
50  AppKit + 0x390c4
    eip = 0x92a0d0c5   esp = 0xbfffe9c0   ebp = 0xbfffea78
    Found by: previous frame's frame pointer
51  XUL!nsAppShell::Run() [nsAppShell.mm:10050c1a0b32 : 863 + 0x72]
    eip = 0x02932dfa   esp = 0xbfffea80   ebp = 0xbfffeb08
    Found by: previous frame's frame pointer
52  XUL!nsAppStartup::Run() [nsAppStartup.cpp:10050c1a0b32 : 182 + 0x7]
    eip = 0x027c0757   esp = 0xbfffeb10   ebp = 0xbfffeb28
    Found by: previous frame's frame pointer
53  XUL!XRE_main [nsAppRunner.cpp:10050c1a0b32 : 3525 + 0x7]
    eip = 0x01e86d69   esp = 0xbfffeb30   ebp = 0xbffff078
    Found by: previous frame's frame pointer
54  firefox-bin!main [nsBrowserApp.cpp:10050c1a0b32 : 158 + 0x18]
    eip = 0x00001d48   esp = 0xbffff080   ebp = 0xbffff0d8
    Found by: previous frame's frame pointer
55  firefox-bin + 0xbf5
    eip = 0x00001bf6   esp = 0xbffff0e0   ebp = 0xbffff0f0
    Found by: previous frame's frame pointer
56  0x6
    eip = 0x00000007   esp = 0xbffff0f8   ebp = 0x00000000
    Found by: previous frame's frame pointer
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 536382
You need to log in before you can comment on or make changes to this bug.