some pages never finish loading - closing them will crash

VERIFIED DUPLICATE of bug 53613

Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 53613
18 years ago
14 years ago

People

(Reporter: R.K.Aa., Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
saw this first time yesterday.
It's also in 2000092110 linux.

several pages, for instance bugzilla query to todays bugs, never stops loading;
throbber goes on throbbing and progress indocator stalls but never stops.
If two windows are open at the time and i close the one that keeps throbbing,
moz crash. No talkback is triggered. This has happened to me some 40 times the
past two days so it's pretty reproducable.

Another thing i notice: Bottom frame (or table) of the queries always have some
links, amongst them one to "log in" or "log out". Even if i'm logged in, that
link on a daily query page always reads "log in" now. Whether this indicates a
cookie bug or not i have no idea.

bt from non-debug:

Program received signal SIGSEGV, Segmentation fault.
0x1 in ?? ()
(gdb) bt
#0  0x1 in ?? ()
#1  0x410581b5 in NSGetModule () from /usr/local/mozilla/components/libgklayout.so
#2  0x4002dd38 in nsRenderingContextImpl::DrawStdLine () from
/usr/local/mozilla/libgkgfx.so
#3  0x40038b25 in XP_NotifyObservers () from /usr/local/mozilla/libgkgfx.so
#4  0x40033347 in il_pixmap_update_notify () from /usr/local/mozilla/libgkgfx.so
#5  0x40037724 in il_flush_image_data () from /usr/local/mozilla/libgkgfx.so
#6  0x400330e1 in ImgDCallbk::ImgDCBFlushImage () from
/usr/local/mozilla/libgkgfx.so
#7  0x4131e644 in NSGetModule () from /usr/local/mozilla/components/libnsgif.so
#8  0x4131d712 in NSGetModule () from /usr/local/mozilla/components/libnsgif.so
#9  0x4131d80b in NSGetModule () from /usr/local/mozilla/components/libnsgif.so
#10 0x4002e487 in ImageSystemServicesImpl::QueryInterface () from
/usr/local/mozilla/libgkgfx.so
#11 0x40a9d602 in _fini () from /usr/local/mozilla/components/libtimer_gtk.so
#12 0x40a9d7cd in _fini () from /usr/local/mozilla/components/libtimer_gtk.so
#13 0x40a9d853 in _fini () from /usr/local/mozilla/components/libtimer_gtk.so
#14 0x408b604d in g_timeout_dispatch () from /usr/lib/libglib-1.2.so.0
#15 0x408b5186 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#16 0x408b5751 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#17 0x408b58f1 in g_main_run () from /usr/lib/libglib-1.2.so.0
#18 0x407dd7b9 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#19 0x4071c70c in NSGetModule () from /usr/local/mozilla/components/libwidget_gtk.so
#20 0x404618ba in inflate_mask () from
/usr/local/mozilla/components/libnsappshell.so
#21 0x804daf7 in JS_PushArguments ()
#22 0x804df56 in JS_PushArguments ()
#23 0x402619cb in __libc_start_main (main=0x804de4c <JS_PushArguments+11356>,
argc=1, argv=0xbffff824,
    init=0x804ad80 <_init>, fini=0x80534ec <_fini>, rtld_fini=0x4000ae60
<_dl_fini>,
    stack_end=0xbffff81c) at ../sysdeps/generic/libc-start.c:92
(gdb)
(Reporter)

Comment 1

18 years ago
log in/log out thing is irrelevant; individual bugs show correct "log out" link
but still don't load completely.
(Reporter)

Comment 2

18 years ago
Raising severity. Even if clicking Stop button prevents the crash, i keep
forgetting that, and all this crashing is getting annoying.
Severity: normal → critical
Keywords: crash

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 53613 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
*spamm*
cleaning out browser general
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.