website: users can't login with valid credentials

VERIFIED FIXED in 2.5

Status

--
major
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: crimius, Unassigned)

Tracking

unspecified
x86
Windows XP

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 (.NET CLR 3.5.30729)
Build Identifier: unknown

upon login, several users are reporting that the login page simply refreshes without logging them in.  as a result, favorites and other functions that require them to be logged in are unavailable.

Reproducible: Always

Steps to Reproduce:
just happens.
Actual Results:  
they are not logged in

Expected Results:  
they should be redirected to the getpersonas.com main page

it has been reported on:
- Windows XP Pro
- Firefox 3.5.6
- Other Addons installed:
- Firebug, YSlow, pixel perfect, Greasemonkey, ColorZilla, Coloriris,
IE Tab, MeasureIt, Tab Sidebar.

-Windows 7

the windows 7 user volunteered to a VNC session if it would help fix this.
Assignee: cbeard → nobody
Component: Personas → getpersonas.com
Product: Mozilla Labs → Websites
QA Contact: personas → getpersonas-com
Target Milestone: -- → ---
I'm guessing this  might be due to some cookie verification code. I'll ask the one of the users experiencing this problem to test on stage with and without the verification checks.
Target Milestone: --- → 2.5

Comment 2

9 years ago
Write me up as another,,,

IF  I do get signed in as soon as I click off that page I am out, can't go to "My account" or anything and it's a real trick to just get logged on in the first place. I seriously don't think it's on my end I NEVER have this kind of problem and I am a HEAVY web user. There are most likely 1000s more like me that haven't taken the time to write about it.

Would be nice to have a Personas favorites list,,, I think anyway never got a chance to see what it is.

I am in Indiana using Wildblue with Vista Home Premium 64 my Wildblue signal comes from Laredo Texas so that is about all I can tell you.

Comment 3

9 years ago
Sorry Firefox 3.6 here

Comment 4

9 years ago
Apparently related to network settings (proxy?). Depending on the network, the same computer with exact same profile gets bug or not.
The bug is found on released version of the website but not on the stage version.
(In reply to comment #4)
> Apparently related to network settings (proxy?). Depending on the network, the
> same computer with exact same profile gets bug or not.
> The bug is found on released version of the website but not on the stage
> version.

That's good to hear, it supports my hypothesis that this is due to a cookie verification based on IP address.
r62976 should fix this issue.


For QA:
I changed the cookie generation and verification to not use the user's IP address. Verification of login/out and testing pages that require login should be tested.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified, FIXED.
Status: RESOLVED → VERIFIED

Comment 8

9 years ago
Still not working for me
(In reply to comment #8)
> Still not working for me

This was fixed on stage, we have a release tmrw night when we will push the code live.

Comment 10

9 years ago
I am also having this problem i cant login, its saying Invalid username or password. Please try again. Then when i go to forget your password and put my details in it says Oops! We are unable to locate the username you entered. Please try again, or create a new one. I have an account my username is Nos Baby Nos but its like it got deleted but my persona is still up there. Fix this please.
@Ashton: the problem you are reporting is not related to this bug. Your username is not 'Nos Baby Nos', it has to be one word with no spaces. 'Nos Baby Nos' is most likely your display name, not login/username.

Comment 12

9 years ago
Can you please help me find my username and password so I can get to my favorites?  I made a new name and password when I couldn't log in, but I am not sure what the username was, just the password.  I usually use cwaldman.  cwaldman@bluefrog.com is my email.  Thanks.  If I have to start over, it's all right.
Christie: please go here: http://www.getpersonas.com/en-US/forgot_password and enter your username. It will email you a reset password link.

Comment 14

8 years ago
Tried the "Forgot Your Password" option several times today without success.  When I created the account last Thursday (11/11)I had FireFox "remember" the credentials. Tried but could not login over the weekend from my laptop at home. Thought I must have forgotten the password but when returned to the office today I still could not login on the PC that I originally used and where FireFox "remembered" the credentials. Checked the Spam folder at my Yahoo account and found nothing there either. 
My Personas login name is CyberKnight, e-mail is osparks@yahoo.com, and I'm very confident I know the password too.  
Oddity! - I just clicked on the FireFox bookmark I saved last Thursday when I created the Personas acct. and it worked!! Logged right in on it's own just as it should have earlier today, but now I'm afraid to ever logout...
Darvin, this bug is already verified as fixed so take a look at the new bug which was filed today: bug 612823

Thanks
(Assignee)

Updated

6 years ago
Component: getpersonas.com → getpersonas.com
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.