Crash Report [@ MimeDecoderWrite(MimeDecoderData*, char const*, int) ]

RESOLVED DUPLICATE of bug 532693

Status

--
critical
RESOLVED DUPLICATE of bug 532693
9 years ago
8 years ago

People

(Reporter: mozilla-bugs, Unassigned)

Tracking

({crash, testcase})

1.9.1 Branch
x86
All
crash, testcase

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
This is from this crash report for Thunderbird 3:
ID: 24217b56-b770-485c-b621-1b1332091203

User comments from crash-stats:
Was browsing my inbox. I tried to open a recent mail, but an old mail from a month or so ago opened instead. I was trying to get the e-mail to display correctly, so I right-clicked and chose 'Edit as new...', which caused this crash.

There is a similar report on Launchpad for Thunderbird 2 with similar comments.

Frame  	Module  	Signature [Expand]  	Source
0 	thunderbird-bin 	MimeDecoderWrite 	mailnews/mime/src/mimeenc.cpp:189
1 	thunderbird-bin 	mime_decompose_file_output_fn 	mailnews/mime/src/mimedrft.cpp:1962
2 	thunderbird-bin 	MimeMessage_parse_line 	mailnews/mime/src/mimemsg.cpp:222
3 	thunderbird-bin 	MimeObject_parse_eof 	mailnews/mime/src/mimeobj.cpp:299
4 	thunderbird-bin 	MimeContainer_parse_eof 	mailnews/mime/src/mimecont.cpp:129
5 	thunderbird-bin 	MimeMessage_parse_eof 	mailnews/mime/src/mimemsg.cpp:542
6 	thunderbird-bin 	mime_parse_stream_complete 	mailnews/mime/src/mimedrft.cpp:1209
7 	thunderbird-bin 	nsStreamConverter::OnStopRequest 	mailnews/mime/src/nsStreamConverter.cpp:1068
8 	thunderbird-bin 	nsImapCacheStreamListener::OnStopRequest 	mailnews/imap/src/nsImapProtocol.cpp:8333
9 	thunderbird-bin 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:576
10 	thunderbird-bin 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:401
11 	libxpcom_core.so 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:111
12 	libxpcom_core.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:521
13 	libxpcom_core.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:236
14 	thunderbird-bin 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
15 	thunderbird-bin 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:193
16 	thunderbird-bin 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3321
17 	thunderbird-bin 	main 	mail/app/nsMailApp.cpp:103
(Reporter)

Updated

9 years ago
Can we get an email in .eml format attached to this bug so we have a testcase and can fix the issue ?
Keywords: crash

Comment 2

9 years ago
This a rare crash, ~2 per month. most don't have comments.
I examined crashes going back to July 10 and emailed submitter of
bp-cb7208d7-c8ab-426e-89a8-60a8f2091107
using 3.0a2
0	thunderbird-bin	MimeDecoderWrite	 mozilla/mailnews/mime/src/mimeenc.cpp:189
1	thunderbird-bin	mime_decompose_file_output_fn	mozilla/mailnews/mime/src/mimedrft.cpp:1969
2	thunderbird-bin	MimeMessage_parse_line	mozilla/mailnews/mime/src/mimemsg.cpp:230
3	thunderbird-bin	MimeObject_parse_eof	mozilla/mailnews/mime/src/mimeobj.cpp:312
4	thunderbird-bin	MimeContainer_parse_eof	mozilla/mailnews/mime/src/mimecont.cpp:129
5	thunderbird-bin	MimeMessage_parse_eof	mozilla/mailnews/mime/src/mimemsg.cpp:550
6	thunderbird-bin	mime_parse_stream_complete	mozilla/mailnews/mime/src/mimedrft.cpp:1246
7	thunderbird-bin	nsStreamConverter::OnStopRequest	mozilla/mailnews/mime/src/nsStreamConverter.cpp:1027 

MimeDecoderWrite(MimeDecoderData*, char const*, int) appears for Mac also but I didn't check if stack is same
OS: Linux → All
(Reporter)

Comment 3

9 years ago
Created attachment 419127 [details]
Test E-Mail that causes crash for LP user
Keywords: testcase

Updated

9 years ago
Attachment #419127 - Attachment mime type: application/x-mimearchive → text/plain

Comment 4

9 years ago
I fixed a crash in the mimedrft code which might fix this problem. The fix is in the 3.01 nightlies, and the 3.1 nightlies. bug 532693 has the fix I'm thinking of.
(Reporter)

Comment 5

9 years ago
Launchpad user confirmed that the 3.0.1 nightly build fixes the problem.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 532693
(Assignee)

Updated

8 years ago
Crash Signature: [@ MimeDecoderWrite(MimeDecoderData*, char const*, int) ]
You need to log in before you can comment on or make changes to this bug.