Closed Bug 536534 Opened 10 years ago Closed 10 years ago

tinderbox log highlighter should make crash stacks show up in short log

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 483061

People

(Reporter: dbaron, Unassigned)

Details

Right now, when the crash reporter prints information about a crash in a tinderbox log, the only line that gets highlighted is the "minidump found" or "crash found" line.  This, however, doesn't actually put the crash stack (which is what people care about) in the short log.

We could get the crash stack in the short log quite easily by highlighting lines of the form:

Thread 0 (crashed)

so that the top of the stack (the log highlighting range) shows up in the shortlog.


The regex we want would be something like (depending on the particular regex syntax):
  ^Thread \d\+ \(crashed\)$
I should have known to look in :future before nagging you into filing this.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483061
Status: RESOLVED → VERIFIED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.